Package Details: jdk6 6u45-7

Git Clone URL: https://aur.archlinux.org/jdk6.git (read-only, click to copy)
Package Base: jdk6
Description: Oracle Java 6 Development Kit (public release - end of support)
Upstream URL: https://www.java.com/en/download/faq/java_6.xml
Keywords: java java6 jdk jdk6
Licenses: custom
Provides: java-environment=6, java-environment-jdk=6, java-runtime=6, java-runtime-headless=6, java-runtime-headless-jre=6, java-runtime-jre=6, java-web-start=6, java-web-start-jre=6
Submitter: Det
Maintainer: severach
Last Packager: Stykers
Votes: 84
Popularity: 0.021096
First Submitted: 2014-10-18 07:16
Last Updated: 2019-07-22 00:23

Dependencies (17)

Required by (1000)

Sources (8)

Latest Comments

1 2 3 4 5 6 Next › Last »

Ketchup901 commented on 2020-03-27 15:41

You can get the appropriate file (jdk-6u45-linux-x64.bin) from here: https://www.oracle.com/java/technologies/javase-java-archive-javase6-downloads.html Put it in the same directory as your PKGBUILD.

AriseEVE commented on 2020-02-03 15:46

https://cdn.stykers.moe/dl/jdk-6u45-linux-x64.bin - dl link is broken, "Invalid SSL certificate"

Magotchi commented on 2019-12-16 15:19

The current source URLs are broken due to a Cloudflare "Origin DNS error". Current x86_64 source: https://cdn.stykers.moe/dl/jdk-6u45-linux-x64.bin .

Stykers commented on 2019-07-22 00:17

moved the hosted file to my CDN, package is usable again

Magotchi commented on 2019-05-22 14:04

The current x86_64 source for this returns an HTTP 404 (Not Found). It's https://www.dropbox.com/s/ym5k71ftapaq4um/jdk-6u45-linux-x64.bin .

rdb commented on 2019-01-19 10:13

I get the same error. To fix, replace this line in PKGBUILD:

rename -- ".jar" "-limited.jar" jre/lib/security/*

With this:

rename -- ".jar" "-limited.jar" jre/lib/security/*.jar

Serra commented on 2019-01-14 10:17

The build fails for me like this:

==> Starting package()... -> Extracting the .bin -> Creating required dirs -> Preparing -> Removing redundancies -> Moving stuff in place rename: jre/lib/security/java.policy: not accessible: No such file or directory rename: jre/lib/security/java.security: not accessible: No such file or directory rename: jre/lib/security/javaws.policy: not accessible: No such file or directory ==> ERROR: A failure occurred in package(). Aborting... ==> ERROR: Build failed, check /var/lib/aurbuild/x86_64/vagrant/build

ItachiSan commented on 2017-06-27 14:25

@Det @wsnark it was working for me, just tested in an Arch Docker container and it did not. Fixed the DLAGENTS, should work now.

Det commented on 2017-06-27 13:46

No, the problem is not the public release (6u45), it's that you can't download even that without logging in anymore.

wsnark commented on 2017-06-27 13:24

The DLAGENTS still points to http variant, so the build fails.

BTW, what about adding an option to download last public release too? For people who do not care about security fixes, but prefer downloading from Oracle?