Package Details: jdk11-openj9-bin 11.0.9b11_openj9_0.23.0-5

Git Clone URL: https://aur.archlinux.org/jdk11-openj9-bin.git (read-only, click to copy)
Package Base: jdk11-openj9-bin
Description: Eclipse (former IBM) OpenJ9 with openjdk11
Upstream URL: https://adoptopenjdk.net/index.html?variant=openjdk11&jvmVariant=openj9
Keywords: jdk openj9 openjdk
Licenses: GPL2
Conflicts: jdk11-openj9
Provides: java-environment=11, java-environment-openjdk=11, java-runtime=11, java-runtime-headless=11, java-runtime-headless-openjdk=11, java-runtime-openjdk=11
Submitter: None
Maintainer: Depau
Last Packager: Depau
Votes: 5
Popularity: 0.000501
First Submitted: 2018-11-30 20:11
Last Updated: 2021-01-18 12:24

Required by (1000)

Sources (1)

Latest Comments

1 2 3 Next › Last »

markusk commented on 2021-01-20 15:57

Kinda bit OffTopic: Remember that pacaur seems to be no longer supported! Last update on AUR is from 2019. I suggest you use other aur helpers from https://wiki.archlinux.org/index.php/AUR_helpers

I don't know if this is connected to the "problem" here. I use and can suggest to use yay, paru, trizen and bauerbill.

Depau commented on 2021-01-19 22:39

BTW I did remove the conflict

shador commented on 2021-01-18 22:03

Ok, thanks Depau. I agree that pacaur should be consistent regarding it's handling of conflicts.

Depau commented on 2021-01-18 12:22

The point is to make it conflict with other packages that provide the same binary.

However, if pacaur doesn't let you install it because of that, you should be investigating what's the problem with pacaur and not with this package.

Pacman's behavior is what is authoritative. If pacaur does not agree with pacman, it's pacaur's fault.

shador commented on 2021-01-18 11:19

@depau Apparently my comment offended you. Sorry, it was not intended that way.

I'm not surprised it works for you. So no proof needed. All I can tell you is that for me with pacaur it does not work. I'm not asking for help to make it work. I don't need it. I never tried to force you to do anything. I respect your opinion. All of this is not the point. Foremost I just want to understand…

What's the point of making this package conflict with itself?

Depau commented on 2021-01-15 15:52

@shador I can't reproduce the issue.

Proof:

Fix your system.

shador commented on 2021-01-13 11:06

Please remove the conflict jdk11-openj9-bin!

This flags this package jdk11-openj9-bin as conflicting with itself, which seems pointless at least to me. Furthermore because of this I cannot install this package using an AUR package manager.

Or please let me at least know why you think it's necessary for this package to conflict with itself. I've already asked about this in a previous comment...

shador commented on 2020-10-16 12:28

Why does this package conflict with itself?

TheGoliath commented on 2020-05-19 21:16

No Problem :)

rprpx commented on 2020-05-19 20:59

Installs without issue now. Thank you for your time!