Package Details: jdk11-jetbrains-imfix 11.0.13.b1751.19-1

Git Clone URL: https://aur.archlinux.org/java11-jetbrains-imfix.git (read-only, click to copy)
Package Base: java11-jetbrains-imfix
Description: JetBrains Java 11 development kit (With patch that allows allow the IME window follow the cursor)
Upstream URL: https://confluence.jetbrains.com/display/JBR/JetBrains+Runtime
Licenses: custom
Conflicts: jdk11-jetbrains
Provides: java-environment=11, java-environment-jetbrains=11, jdk11-jetbrains=11.0.13.b1751.19-1
Submitter: huyz
Maintainer: huyz
Last Packager: huyz
Votes: 1
Popularity: 0.033318
First Submitted: 2020-11-20 08:51
Last Updated: 2021-11-18 12:16

Dependencies (30)

Required by (887)

Sources (6)

Latest Comments

aquatic7 commented on 2021-11-30 17:54

Why do I get the following error when I try to update?: Building java11-jetbrains-imfix... ==> ERROR: PKGBUILD does not exist.

huyz commented on 2021-11-13 05:29

This package now bundles JCEF so that Jetbrains IDEs can preview markdown files.

Because I have no idea that the bundled JCEF libs should be put into the headless or non-headless package, I merge them into one package. One may need to uninstall the old package before install the new one.

qwivan commented on 2021-01-21 10:59

It should be explicit declared to makedepend on jdk11-openjdk

huyz commented on 2020-12-25 03:52

@bruceutut I upgraded this package to latest version, please have a try.

Note that upstream version is not always increasing, and 1207.1 -> 1145.63 is an upgrade. You can check upstream version in this page: https://bintray.com/jetbrains/intellij-jbr/jbrsdk11-linux-x64

bruceutut commented on 2020-12-25 03:30

The markdown preview is not working on IDEA 2020.3 when using this as the default runtime.

huyz commented on 2020-12-10 02:03

Also this package is not conflict with the jre-jetbrains binary package.

huyz commented on 2020-12-10 02:02

@comfix This package just provides jre11-jetbrains, the provided package doesn't need to be exist I think. (e.g. package xxx-bin and provides xxx, package xxx doesn't need to be exist.)

comfix commented on 2020-12-09 20:46

Please fix the PKGBUILD, there is no "jre11-jetbrains" you are referencing, only a "jre-jetbrains". Other than that nice work tho!