Package Details: jdk11-graalvm-bin 21.1.0-1

Git Clone URL: https://aur.archlinux.org/jdk11-graalvm-bin.git (read-only, click to copy)
Package Base: jdk11-graalvm-bin
Description: Universal virtual machine for running applications written in a variety of languages (JVM-based, LLVM-based, or other), Java 11 version
Upstream URL: https://www.graalvm.org/
Licenses: custom
Provides: java-environment=11, java-runtime=11
Submitter: lucaswerkmeister
Maintainer: lucaswerkmeister
Last Packager: lucaswerkmeister
Votes: 14
Popularity: 0.97
First Submitted: 2019-11-25 00:20
Last Updated: 2021-04-22 09:18

Dependencies (3)

Required by (1000)

Sources (2)

Latest Comments

lucaswerkmeister commented on 2021-04-20 20:58

Note: since the 21.0.0 release, the Node.js component is no longer included in this package. You can install it separately via the graal-nodejs-jdk11-bin package.

florensie commented on 2021-03-07 00:36

Actually yeah, now that I think about it that makes sense. It's probably fine as is. It's the same thing as the java command with multiple JDKs really.

lucaswerkmeister commented on 2021-03-04 20:37

If you make GraalVM your default JDK, then gu should be in your $PATH via /usr/lib/jvm/default/bin. Otherwise, I’m not sure how to solve that. I can’t just symlink /usr/bin/gu to it, because the jdk8 and jdk11 packages should be installable side-by-side. Any ideas?

florensie commented on 2021-03-04 12:46

Looks like gu isn't added to the PATH. /usr/lib/jvm/java-11-graalvm/bin/gu

lucaswerkmeister commented on 2020-01-28 00:19

Done, thanks!

alex4o commented on 2020-01-27 13:36

Hello, as there is now an aarch64 version of the graalvm build (https://github.com/graalvm/graalvm-ce-builds/releases/download/vm-19.3.1/graalvm-ce-java11-linux-aarch64-19.3.1.tar.gz) , do you think that a different package would be needed for the aarch64 platform or this package can provide for both?