Package Details: jameica 2.8.6-1

Git Clone URL: https://aur.archlinux.org/jameica.git (read-only, click to copy)
Package Base: jameica
Description: free runtime environment for java applications
Upstream URL: https://www.willuhn.de/products/jameica/
Licenses: GPL2
Submitter: jakob
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 78
Popularity: 0.26
First Submitted: 2006-10-21 16:11
Last Updated: 2019-11-01 16:41

Dependencies (6)

Required by (3)

Sources (9)

Pinned Comments

fordprefect commented on 2020-03-06 08:28

In case of unknown PGP key run gpg --receive-keys 5A8ED9CFC0DB6C70

Latest Comments

1 2 3 4 5 6 ... Next › Last »

fordprefect commented on 2020-07-02 11:20

@j.r: We call it tradition. Joke aside, I will look into moving it to the proper places, thanks. However, this does not seem super urgent, so it might just happen with the next update or even after if RL is prohibitive.

j.r commented on 2020-07-02 11:10

Could I ask why it is just installed into /opt and not installed according to https://wiki.archlinux.org/index.php/Java_package_guidelines ?

fordprefect commented on 2020-03-06 08:28

In case of unknown PGP key run gpg --receive-keys 5A8ED9CFC0DB6C70

dasarne commented on 2020-03-05 19:15

@fordprefect: Sorry, but it doesn't install: jameica-linux64-2.8.6.zip ... FEHLGESCHLAGEN (Unbekannter öffentlicher Schlüssel 5A8ED9CFC0DB6C70) ==> FEHLER: Eine oder mehrere PGP-Signaturen konnten nicht überprüft werden! Error downloading sources: jameica

fordprefect commented on 2019-04-30 06:59

@Taijian: thx, fixed.

Taijian commented on 2019-04-29 23:27

Another nitpick: Jameica does not actually use gtk2 any more. GTK3 is the standard on Linux since 2.8.3 - therefore gtk2 can be removed as a dependency.

See here: https://www.willuhn.de/blog/index.php?/archives/794-Jameica-2.8.3.html

Taijian commented on 2019-03-21 21:24

Also, in order to make jameica use java8 on systems where it is installed, you could patch the starter like so:

if [ -d /usr/lib/jvm/java-8-openjdk/bin/ ]; then export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH fi

That would help people who usually use a newer java version but would still like to also use mashup (which is still stuck at java 8).

Taijian commented on 2019-03-21 21:00

Just a nitpick/heads-up: According to the author of mashup, java-jce_ustrength is no longer required since Java 8.u161. See: https://hibiscus-mashup.derrichter.de/index.php/faq?id=94:unlimited-strength-java&catid=94

fordprefect commented on 2019-03-14 12:08

@stepborc: please import the key and try again: gpg --receive-keys 5A8ED9CFC0DB6C70. You can setup gpg autoretrieve as well.

@mareex: jre versions are a mess. jre above 9 includes java-jce_ustrength, which otherwise needs to be supplied as dependency. However, some jameica plugins (notably mashup) require the oracle java in version 8 (still the suggested version at their website). so, i agree that enforcing java-environment>10 does not really make sense, the fractured java ecosystem is not easy to handle in this case.

stepborc commented on 2019-03-09 07:41

Unfortunately there is a problem with the public key.

"FEHLGESCHLAGEN (Unbekannter öffentlicher Schlüssel 5A8ED9CFC0DB6C70)"