Package Details: jade-application-kit 3.5.6-2

Git Clone URL: https://aur.archlinux.org/jade-application-kit.git (read-only, click to copy)
Package Base: jade-application-kit
Description: Build desktop applications using web technologies on Linux, with Python, JavaScript, HTML5, and CSS3 and webkit.
Upstream URL: https://github.com/codesardine/Jade-Application-Kit
Licenses: GPL3
Conflicts: jade-application-kit-git
Provides: jade-application-kit
Submitter: prasadkumar013
Maintainer: ydallilar
Last Packager: ydallilar
Votes: 5
Popularity: 0.69
First Submitted: 2018-04-18 18:43
Last Updated: 2021-04-06 15:38

Pinned Comments

ydallilar commented on 2021-04-13 06:10

Try this please:

git clone https://aur.archlinux.org/jade-application-kit.git
cd jade-application-kit
makepkg -si

If it also fails, then post.

Latest Comments

1 2 Next › Last »

ydallilar commented on 2021-04-13 06:10

Try this please:

git clone https://aur.archlinux.org/jade-application-kit.git
cd jade-application-kit
makepkg -si

If it also fails, then post.

b2gcoder commented on 2021-04-13 03:07

Making package: jade-application-kit 3.5.6-2 (Mon 12 Apr 2021 11:06:42 PM EDT) ==> Retrieving sources... -> Found v3.5.6.tar.gz ==> Validating source files with sha512sums... v3.5.6.tar.gz ... FAILED ==> ERROR: One or more files did not pass the validity check!

ydallilar commented on 2021-04-09 07:46

Check you build cache. I can't reproduce it.

longbrow commented on 2021-04-08 17:05

The validity check still fails

ydallilar commented on 2021-04-06 15:40

Strange. Should be ok now.

RealStickman commented on 2021-04-06 06:36

I had two errors when building the most recent pkgbuild. The first was the failing validity check. The second was an incorrect build directory in "src". See the diff below.

$ diff -u PKGBUILD_OLD PKGBUILD_NEW 
--- PKGBUILD_OLD    2021-04-06 08:28:01.555549575 +0200
+++ PKGBUILD_NEW    2021-04-06 08:27:32.670550985 +0200
@@ -15,19 +15,19 @@
 depends=('python' 'python-gobject' 'webkit2gtk' 'pyside2' 'python-pyqtwebengine')
 makedepends=('python-setuptools')
 source=("https://github.com/codesardine/Jade-Application-Kit/archive/v${pkgver}.tar.gz")
-sha512sums=('2e41c765f64f9add00a4c467a474f19397d27a19d1b02243167f53cfdefe9b3e34f0f1a3de0a9c61a40df1ec0fb6bcdde26731c0e9a3195a6348fc46ee8289c7')
+sha512sums=('5d1e65763371fe61e56eded78092f94737381a4707edac8b87003264c236b88ebc1db159c00e639ef8686e15489977b1fd3dfdbd00c53934aa1b4a38f9ad9454')

 prepare() {
-    cd "${srcdir}"/Jade-Application-Kit-${pkgver}
+    cd "${srcdir}"/jak-${pkgver}
    #patch --strip=1  < ../import_fix.patch
 }

 build() {
-    cd "${srcdir}"/Jade-Application-Kit-${pkgver}
+    cd "${srcdir}"/jak-${pkgver}
     python setup.py build
 }

 package() {
-    cd "${srcdir}"/Jade-Application-Kit-${pkgver}
+    cd "${srcdir}"/jak-${pkgver}
     python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
 }

spsf64 commented on 2020-11-23 00:58

v3.5.5.tar.gz ... FAILED==> ERROR: One or more files did not pass the validity check! Using updpkgsums fixed the problem...

ydallilar commented on 2020-07-02 11:33

No need to be aggressive about it. It is AUR rule. Can't make an exception for you.

bkb commented on 2020-07-02 11:07

So I have to found a packet in AUR who has added in his dependencies in order to not install those as Explicit because you willn't add it as a dependence, nice

ydallilar commented on 2020-07-02 10:28

@bkb Note: Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as build dependencies explicitly.

patch is in base-devel