Package Details: itch 1:1.26.0-1

Git Clone URL: https://aur.archlinux.org/itch.git (read-only, click to copy)
Package Base: itch
Description: The best way to play itch.io games.
Upstream URL: https://github.com/itchio/itch
Licenses: MIT
Submitter: FrozenCow
Maintainer: Paragoumba
Last Packager: Paragoumba
Votes: 98
Popularity: 2.48
First Submitted: 2015-12-14 22:23
Last Updated: 2021-05-12 12:15

Pinned Comments

Paragoumba commented on 2021-05-18 13:36

If while updating the package you get the error One or more files did not pass the validity check!, please follow these instructions:

  • delete the file that didn't pass the check,
  • try to build the package again.

This error nearly always comes from a network error. If after trying again it still doesn't work, post a comment here and I will check.

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 Next › Last »

papabean commented on 2016-11-21 00:02

Just built it successfully. Thanks for the updated PKGBUILD

fasterthanlime commented on 2016-11-20 21:25

v20.0.0 is out, which should fix the tests issue!

@undefinedmethod: nodejs-grunt-cli is a dependency of this package, so I'm not sure what's happening for you?

undefinedmethod commented on 2016-11-20 21:11

The tests for this app will fail for me unless I install the grunt-cli prior to pulling and building.

fasterthanlime commented on 2016-11-20 11:33

The `join` issue has been fixed upstream, it'll be part of the next stable release. (A friendly Arch user confirmed that `kitch` (our beta channel) does indeed install correctly).

kaptoxic commented on 2016-11-20 05:54

I also get the testing error -- perhaps you should move the testing part of the build to test() inside PKGBUILD?

jurf commented on 2016-11-13 20:57

I can't update to 19 either, I don't know why but I always have problems with this package.

erbridge commented on 2016-11-13 17:55

This issue is preventing update to 19.0.0.

fasterthanlime commented on 2016-11-02 16:09

@thinhakapete I remember seeing this error in our CI logs, but the 19.0.0 build definitely passed! Something fishy's going on...

thinhakapete commented on 2016-11-02 04:08

[itch 19.0.0-1]

not ok 39 should be equivalent
---
operator: deepEqual
expected: |-
{ errors: [ 'foo', 'bar', 'baz' ] }
actual: |-
[TypeError: Cannot read property 'join' of undefined]
at: Generator.tryCatcher (/tmp/yaourt-tmp-heo/aur-itch/src/itch-19.0.0/node_modules/bluebird/js/release/util.js:16:23)

==> ERROR: A failure occurred in check().


fasterthanlime commented on 2016-08-08 07:56

@papabean Looks like it was an upstream bug, and they fixed it: https://github.com/electron-userland/electron-packager/issues/439 - no need to update the PKGBUILD!