Package Details: itch 1:1.26.0-1

Git Clone URL: https://aur.archlinux.org/itch.git (read-only, click to copy)
Package Base: itch
Description: The best way to play itch.io games.
Upstream URL: https://github.com/itchio/itch
Licenses: MIT
Submitter: FrozenCow
Maintainer: Paragoumba
Last Packager: Paragoumba
Votes: 103
Popularity: 2.18
First Submitted: 2015-12-14 22:23
Last Updated: 2021-05-12 12:15

Pinned Comments

Paragoumba commented on 2021-05-18 13:36

If while updating the package you get the error One or more files did not pass the validity check!, please follow these instructions:

  • delete the file that didn't pass the check,
  • try to build the package again.

This error nearly always comes from a network error. If after trying again it still doesn't work, post a comment here and I will check.

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 13 14 Next › Last »

jurf commented on 2016-06-04 06:47

The build fails for me:

Running "electron:linux-x64" (electron) task
Verifying property electron.linux-x64 exists in config...OK
File: [no files]
Options: dir="stage", name="itch", version="1.2.0", app-version="17.6.6", prune, asar, overwrite, out="build/v17.6.6", platform="linux", arch="x64"
Packaging app for platform linux x64 using electron v1.2.0
Warning: ENOENT: no such file or directory, link '/tmp/electron-packager/linux-x64/itch-linux-x64/electron' -> '/tmp/electron-packager/linux-x64/itch-linux-x64/itch' Use --force to continue.

Aborted due to warnings.

FrozenCow commented on 2016-05-14 17:44

@tesfabpel ugh, you're right. It's the `bundle install` command I think. I already have rubygems installed on my system, but outside of pacman. Will check what needs to be done to get this through pacman.

tesfabpel commented on 2016-05-14 16:09

Why the package wants to install rubygems system-wide in the build() phase (and asks the root password)?

mnt/CommonExtraLinuxFiles/tmp/yaourt-tmp-tesx/aur-itch/src/itch-17.6.0/release/common.rb:5:in `system': Interrupt
from /mnt/CommonExtraLinuxFiles/tmp/yaourt-tmp-tesx/aur-itch/src/itch-17.6.0/release/common.rb:5:in `<top (required)>'
sudo: 1 tentativo di immissione password non corretto from release/ci-compile.rb:4:in `require_relative'

from release/ci-compile.rb:4:in `<main>'

FrozenCow commented on 2016-05-14 11:17

@DoctorJellyface, it should be working now. The fix was pushed to the itch repo as well: https://github.com/itchio/itch/pull/654

@fasterthanlime, thanks for the new version and all the work. Have a great vacation!

jurf commented on 2016-05-14 08:36

Can you at least post the fix here so we can build it in the meantime?

fasterthanlime commented on 2016-05-14 06:33

Fixed in master but I can't push tag from vacation. Will fix when I'm back!

fasterthanlime commented on 2016-05-14 06:24

Ah, yes, the ln call is definitely incomplete.

fasterthanlime commented on 2016-05-14 06:16

@erbridge It's supposed to be a symlink now. Maybe I got the invocation wrong? PRs welcome on https://github.com/itchio/itch to modify PKGBUILD.in

erbridge commented on 2016-05-13 21:04

@fasterthanlime: the latest update has removed the itch executable from the PATH. The last line of the PKGBUILD looks pretty suspect to me, too.

fasterthanlime commented on 2016-05-13 11:53

This package is now automatically kept up-to-date by the itch.io continuous delivery servers, so it shouldn't lag behind official releases anymore!