Package Details: itch 1:1.24.0-6

Git Clone URL: https://aur.archlinux.org/itch.git (read-only, click to copy)
Package Base: itch
Description: The best way to play itch.io games.
Upstream URL: https://github.com/itchio/itch
Licenses: MIT
Submitter: FrozenCow
Maintainer: Paragoumba
Last Packager: Paragoumba
Votes: 97
Popularity: 1.55
First Submitted: 2015-12-14 22:23
Last Updated: 2021-04-05 14:15

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Paragoumba commented on 2021-04-05 14:16

@Gamma Good catch, I updated the package

Gamma commented on 2021-04-04 18:27

Your heredoc (which makes /usr/bin/itch) has @$ instead of $@:

  cat << 'BE_KIND' > itch
#!/bin/sh
itch-setup --prefer-launch -- "$@"
BE_KIND

Single quotes around BE_KIND prevent the "$@" from expanding in the heredoc.

laurentO commented on 2021-03-12 07:01

Today I still have issues when updating with yay, but I managed to update using pakku

when I run the command yay -Syu itch, these are the packages to update

:: 6 Paquets à mettre à jour.
6  aur/dotnet-host-bin            5.0.3.sdk200-1 -> 5.0.4.sdk201-1
5  aur/dotnet-runtime-bin         5.0.3.sdk200-1 -> 5.0.4.sdk201-1
4  aur/dotnet-sdk-bin             5.0.3.sdk200-1 -> 5.0.4.sdk201-1
3  aur/dotnet-targeting-pack-bin  5.0.3.sdk200-1 -> 5.0.4.sdk201-1
2  aur/electron9                  9.4.3-1        -> 9.4.4-2
1  aur/itch                       1:1.24.0-4     -> 1:1.24.0-5

But the command fails with the error:

curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.
==> ERREUR : Erreur lors du téléchargement de https://github.com/itchio/itch/archive/v25.4.1.tar.gz

so I used pakku with the command pukku -Syu itch. It detected the same dependencies, but removed electron9 because it was in conflit with dotnet (WTF ?)

Finally the process ran well, and electron9 was finally present on my system (perhaps installed in my previous tries).

Very strange behavior IMO !

starquake commented on 2021-03-09 14:02

@laurentO

I just built this in about 10 seconds. The resulting build dir was 63M.

Did you build it yourself? Or did your aur helper just screw up?

You should really try to build it manually.

laurentO commented on 2021-03-08 11:08

I don't understand how to install it in an easy way from AUR Today, trying to get get it from AUR needs more than 8 Gb !! of free space in /tmp for electron9 download and build. With a 8 Gb partition for /tmp , the process ran out of free space after 86% of git syncing and compilation.

It's insane for a just an app !!!

I simply can not build it without changing my file system. RIDICULOUS !

Totally idiot from the editor

Electron Apps are great for compatibility but are a SHAME for updating

I'll try to get it directly from their web site, to see if a direct download can reduce disk space costs during installation

Paragoumba commented on 2021-03-01 15:32

Gconf and other dependencies seem unneeded but itch crashes when the package is built without them. Will check and fix it all asap

icewind commented on 2021-03-01 14:42

The dependency on gconf seems unneeded, it seems to work just fine without it

ReNoM commented on 2020-11-10 13:27

@Paragoumba Hey, thanks for updating the package. I'm getting rid of gtk2, installed a gtk3 gimp version.

Paragoumba commented on 2020-11-09 16:58

@ReNoM I launched itch without installing gtk2 and it seems to work so I removed it from the dependencies. As I couldn't find an official list of the required dependencies, I can't confirm it won't cause problems, I'll update the dependencies if necessary.

ReNoM commented on 2020-11-09 13:49

Hi. Does it actually require gtk2?