Package Details: iscan-plugin-gt-s650 2.30.4-2

Git Clone URL: https://aur.archlinux.org/iscan-plugin-gt-s650.git (read-only, click to copy)
Package Base: iscan-plugin-gt-s650
Description: EPSON Image Scan! plugin for Epson scanners (DS, EP, ES, ET, EW, L, LX, PX, WF, XP Series, FF-640, GT-S650, Perfection V19, Perfection V39)
Upstream URL: http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
Licenses: custom:EPSON EULA
Submitter: Muflone
Maintainer: Muflone
Last Packager: Muflone
Votes: 10
Popularity: 1.01
First Submitted: 2015-11-07 20:14
Last Updated: 2020-07-26 17:44

Pinned Comments

Muflone commented on 2020-01-24 16:23

Package updated.

Since now this package will follow the iscan package version used to distribute the plugin, instead of the internal numbering into the package, as EPSON people won't respect version number history

Latest Comments

YAOMTC commented on 2020-07-25 01:23

Another new sha256sum. Should be: 553eb55fef42ebcae562f3b8442d43093a16d8b53893da3b0d25396e81377949

Muflone commented on 2020-01-24 16:23

Package updated.

Since now this package will follow the iscan package version used to distribute the plugin, instead of the internal numbering into the package, as EPSON people won't respect version number history

alex-y commented on 2020-01-22 16:52

==> Récupération des sources… -> iscan-gt-s650-bundle-2.30.4.x64.deb.tar.gz trouvé ==> Validation des fichiers source avec sha256sums… iscan-gt-s650-bundle-2.30.4.x64.deb.tar.gz ... ÉCHEC ==> ERREUR : Un ou plusieurs fichiers ne sont pas valides ! Impossible de construire iscan-plugin-gt-s650

DwarfNr5 commented on 2019-12-15 09:28

@user202729, How do I apply a patch to PKGBUILD (I never had to do this before and Google didn't answer it clearly)

user202729 commented on 2019-09-25 06:46

Currently the old version is deleted from the offical page. To use the new version instead it's possible to apply this patch to the PKGBUILD:

--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,11 @@ url="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
 license=('custom:AVASYSPL')
 depends=('iscan' 'iscan-data')
 _plugin=${pkgname/iscan-plugin-/}
-_iscan_ver=1.0.0
-_plugin_rel=2
-_file_ver=1.1.0
+_iscan_ver=2.30.4
+_plugin_rel=1
+_file_ver=1.1.1
 source=("https://download2.ebz.epson.net/iscan/plugin/${_plugin}/deb/x64/iscan-${_plugin}-bundle-${_iscan_ver}.x64.deb.tar.gz")
-sha256sums=('d27e55652942f7c6e5f7f1b09296b742751c872e3963f8167e1f66fe360d9226')
+sha256sums=('9aa06f81bbdf51947ba8bb42f86827b1e3f7cfb9b8987031db735be3141e1dd2')
 install="${pkgname}.install"

 build() {
@@ -42,5 +42,4 @@ package() {
   install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "share/doc/${pkgname}/NEWS"
   # Install licenses
   install -m 755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
-  install -m 644 "share/doc/${pkgname}/AVASYSPL.en.txt" "${pkgdir}/usr/share/licenses/${pkgname}/AVASYSPL"
 }

I don't know why the license file is missing.