Package Details: ipe 7.2.20-3

Git Clone URL: https://aur.archlinux.org/ipe.git (read-only, click to copy)
Package Base: ipe
Description: The extensible drawing editor
Upstream URL: http://ipe.otfried.org/
Licenses: GPL
Conflicts: ipe
Submitter: foxcub
Maintainer: foxcub
Last Packager: foxcub
Votes: 76
Popularity: 0.167408
First Submitted: 2007-01-02 01:58
Last Updated: 2020-08-07 22:40

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 13 14 Next › Last »

evnu commented on 2011-02-11 19:00

ipe currently fails to build due to pdftoipe:

make[1]: Leaving directory `/home/evnu/src/arch/x64/ipe/ipe/src/ipe-7.0.13/src'
make: Für das Ziel »all« ist nichts zu tun.
cc -march=x86-64 -mtune=generic -O2 -pipe -I/usr/include/poppler -c -o parseargs.o parseargs.c
In file included from parseargs.h:30:0,
from parseargs.c:30:
/usr/include/poppler/goo/gtypes.h:31:14: Fehler: expected »=«, »,«, »;«, »asm« or »__attribute__« before »GBool«
In file included from parseargs.c:30:0:

I believe this bug is related to http://bugs.gentoo.org/show_bug.cgi?id=349942 .

foxcub commented on 2011-01-21 06:44

bram85, the problem with the -j flags for make should be fixed now. (There was a typo in the Makefile, so I've added a patch until it's fixed upstream.) Try it, let me know if it doesn't work for you.

foxcub commented on 2011-01-17 21:31

Thanks, vesath. I knew about the problem, but hadn't had a chance to upload the fix. It's up now, and is a little simpler than using sed. Let me know if it doesn't work for you.

vesath commented on 2011-01-17 21:11

To build IpePresenter, Ipe's library and header files need to be found; if Ipe is not installed on the system when building IpePresenter (e.g. if you build in a clean chroot, or if it is the first time you build this package), this will fail.
To solve this problem, point IpePresenter's Makefile to the directory where Ipe was just installed by adding -I$pkgdir/usr/include and -L$pkgdir/usr/lib to the flags.
See the two lines of sed that I have added to the PKGBUILD in there: http://arch.vesath.org/all/ipe-7.0.13-6.src.tar.xz (I can't copy them directly here because of the CR characters in IpePresenter's Makefile.)

foxcub commented on 2011-01-17 16:49

Thanks, xduugu. I need to make another update, so I'll roll the two together soon.

xduugu commented on 2011-01-17 16:48

pdftoipe has been updated. New name: pdftoipe-20110116.tar.gz

xduugu commented on 2011-01-17 16:47

pdftoipe was update. New name: pdftoipe-20110116.tar.gz

foxcub commented on 2010-12-06 19:42

lpb612, it's a bug. Thanks for catching it; I don't use svgtoipe, so I would have never noticed it myself. The new PKGBUILD fixes the problem (and patches the issue with python2).

Anonymous comment on 2010-12-06 04:18

Your tarball has some issues. You've accidentally tarred up some dotfiles. This includes:
.hg_archival.txt
To avoid tarring the wrong files, use "makepkg --source". Please fix this.

Anonymous comment on 2010-12-05 22:40

/usr/bin/svgtoipe does not have execute permission. Is this intentional (due to python upgrade)? If not, it should be given 755 permission.