Package Details: ipe 7.2.20-3

Git Clone URL: https://aur.archlinux.org/ipe.git (read-only, click to copy)
Package Base: ipe
Description: The extensible drawing editor
Upstream URL: http://ipe.otfried.org/
Licenses: GPL
Conflicts: ipe
Submitter: foxcub
Maintainer: foxcub
Last Packager: foxcub
Votes: 76
Popularity: 0.059914
First Submitted: 2007-01-02 01:58
Last Updated: 2020-08-07 22:40

Latest Comments

1 2 3 4 5 6 ... Next › Last »

aquilarubra commented on 2020-08-12 09:25

I get an update error at launch: WhatsApp works with Google Chrome 49+... UPDATE GOOGLE CHROME". Cannot get past that. As a temporary solution, it is possible to delete the settings folder and it will ask login again and work till you close it again:
rm -fr ~/.config/whatsapp-nativefier*

titanx8888 commented on 2020-08-08 08:52

Changing the lua dependency to lua53 works. Thanks.

foxcub commented on 2020-08-07 19:50

Can you try changing lua dependency to lua53?

titanx8888 commented on 2020-08-07 13:01

Unable to build after latest lua update. Lot of errors not being able to find lua53 package.

foxcub commented on 2020-06-27 16:58

Good idea. Done.

Ifidefix commented on 2020-06-27 09:59

On a clean install, icons were not showing. Fixed by installing qt5-svg explicitly, which is an optional dependency of qt5-base. Should this package be added as a dependency?

foxcub commented on 2020-05-02 20:44

@Liquen Interesting. Thanks. I've added gsl as a dependency.

Liquen commented on 2020-05-02 16:55

@foxcub I got the following error when compiling:

ipegeo.cpp:41:10: fatal error: gsl/gsl_vector.h: No such file or directory
   41 | #include <gsl/gsl_vector.h>
      |          ^~~~~~~~~~~~~~~~~~

Fixed after installing gsl. Perhaps this package should be added to depends?

This seems to be new in 7.2.16.

kkl2401 commented on 2020-04-27 17:21

On a new computer, I'm no longer able to build this package (I've tried several different versions with the same result):

mkdir -p ../../build/bin
g++ -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -o ../../build/bin/ipetoipe ../../build/obj/ipetoipe/ipetoipe.o -L../../build/lib -lipe
/usr/bin/ld: ../../build/lib/libipe.so: undefined reference to `png_get_valid'
/usr/bin/ld: ../../build/lib/libipe.so: undefined reference to `png_create_info_struct'
...
collect2: error: ld returned 1 exit status

Does someone have an idea why? I suspect something related to libpng but can't figure out what.

alderz commented on 2019-12-24 15:03

It seems the download link has changed, instead of http://dl.bintray.com/otfried/generic/ipe/7.2/ipe-7.2.13-src.tar.gz it is http://dl.bintray.com/otfried/generic/ipe/7.2/:ipe-7.2.13-src.tar.gz (notice the colon after the last slash). The md5sum seems to have changed to 8cca5643ffb7182cca9c2e154b44cb5e.