Package Details: iota-trinity-wallet 1.1.0-1

Git Clone URL: https://aur.archlinux.org/iota-trinity-wallet.git (read-only)
Package Base: iota-trinity-wallet
Description: The IOTA Trinity Wallet
Upstream URL: https://trinity.iota.org/
Keywords: IOTA
Licenses: Apache
Provides: iota-trinity-wallet
Submitter: TrueRandom
Maintainer: TrueRandom
Last Packager: TrueRandom
Votes: 7
Popularity: 0.026940
First Submitted: 2018-08-26 18:45
Last Updated: 2019-09-20 15:36

Latest Comments

1 2 Next › Last »

archee commented on 2019-07-08 19:09

Hurray! Version 1.0 got released! https://github.com/iotaledger/trinity-wallet/releases/tag/desktop-1.0.0

rsolvang commented on 2019-05-17 17:28

Just installed the Trinity wallet and I get this error messages when starting from a terminal (probably Electron-related):

internal/modules/cjs/loader.js:604
    throw err;
    ^

Error: Cannot find module '../dialog'
    at Module._resolveFilename (internal/modules/cjs/loader.js:602:15)
    at Function.Module._resolveFilename (/opt/iota-trinity-wallet/resources/electron.asar/common/reset-search-paths.js:35:12)
    at Function.Module._load (internal/modules/cjs/loader.js:528:25)
    at Module.require (internal/modules/cjs/loader.js:658:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.get [as dialog] (/opt/iota-trinity-wallet/resources/electron.asar/browser/api/exports/electron.js:11:16)
    at process.<anonymous> (/opt/iota-trinity-wallet/resources/electron.asar/browser/init.js:54:31)
    at process.emit (events.js:182:13)
    at process.emit (/opt/iota-trinity-wallet/resources/app.asar/node_modules/source-map-support/source-map-support.js:461:21)
    at process._fatalException (internal/bootstrap/node.js:451:27)

TrueRandom commented on 2019-02-22 13:25

I added libsecret, not sure about gnome-keyring which seems to be DE dependent

archee commented on 2019-02-15 23:07

At first launch Trinity app is complaining about a mission depdendency: libsecret

It says I may run

pacman -S libsecret

Then I discovered that libsecret is already installed on my system, but since I'm running KDE it's actually mission gnome-keyring (what is also mentioned at Trinities complaint screen)

Maybe PKGBUILD could mention this dependency too?

TrueRandom commented on 2018-10-18 12:25

@rgeorgy see https://unix.stackexchange.com/questions/346973/unknown-public-key-8f0871f202119294-on-archlinux

rgeorgy commented on 2018-10-18 11:05

==> Verifying source file signatures with gpg...
    trinity-desktop-0.3.6.AppImage ... FAILED (unknown public key 6C0CDB3BBCA555C7)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build iota-trinity-wallet.

xsmile commented on 2018-08-31 17:32

@TrueRandom: That works too, I pushed the change. Thanks.

TrueRandom commented on 2018-08-31 17:01

@xsmile I added you as a maintainer, feel free to update the PKGBUILD, I will have a look how to change the suffix the next days

xsmile commented on 2018-08-31 10:49

@TrueRandom: johnnybash described it well. You can refer to the electrum wallet PKGBUILD for an example.

I couldn't find it in the wiki either. The VCS package guidelines mention several suffixes but they obviously don't cover binaries. I'm not sure about the renaming process.

johnnybash commented on 2018-08-31 08:45

according to the PKGBUILD posted on the old Wallet it should look like: validpgpkeys=('466385BD0B40D9550F93C04746A440CCE5664A64')

I think you have to add the .asc file to Sources also to make this work.

https://aur.archlinux.org/packages/iota-wallet-bin/