Package Details: ios-webkit-debug-proxy 1.8.6-1

Git Clone URL: https://aur.archlinux.org/ios-webkit-debug-proxy.git (read-only, click to copy)
Package Base: ios-webkit-debug-proxy
Description: DevTools proxy (WebKit Remote Debugging) for iOS devices (Safari Remote Web Inspector)
Upstream URL: https://github.com/google/ios-webkit-debug-proxy
Licenses: BSD
Submitter: mtorromeo
Maintainer: None
Last Packager: mtorromeo
Votes: 9
Popularity: 0.38
First Submitted: 2014-11-13 14:19
Last Updated: 2020-03-09 10:43

Latest Comments

kuba09 commented on 2020-05-07 12:04

--- solution at the end ---

@raw weird. My build is still failing. Doesn't make a difference if I use an AUR helper or not. The build also fails when making directly from the master branch. I've got these dependencies installed:

  • libimobiledevice-git 1:1.2.0.r178.g857fc15-1
  • libusbmuxd-git 2.0.1.r5.g98f2f23-1
  • usbmuxd-git 1:1.1.0.r71.gb6471b7-1
  • libplist-git 1:2.1.0.r18.gfbee194-1
webinspector.c:95:32: error: field 'type' has incomplete type
   95 |   enum idevice_connection_type type;
      |                                ^~~~
webinspector.c: In function 'idevice_connection_get_ssl_session':
webinspector.c:117:24: error: 'CONNECTION_USBMUXD' undeclared (first use in this function)
  117 |   if (!c || c->type != CONNECTION_USBMUXD || c->data <= 0) {
      |                        ^~~~~~~~~~~~~~~~~~

EDIT: I got the build working by manually installing libimobiledevice from their master branch. It still fails when installing the AUR package, though.

raw commented on 2020-04-30 11:55

installing libimobiledevice-git makes the build run fine.

kuba09 commented on 2020-03-09 15:41

Seems like today's update broke the build. v1.8.6 release notes say that libimobiledevices is required to be built with openssl, the package in the extra repository is flagged out of date at the time of writing.

migerh commented on 2016-10-11 19:59

Removing the -Werror from configure.ac is no longer necessary. It builds without errors and warnings now.

suoko commented on 2015-06-18 09:41

Everything works with:

idevicepair validate
idevicepair pair
chrome-devtools://devtools/bundled/devtools.html?ws=localhost:9222/devtools/page/1

https://github.com/google/ios-webkit-debug-proxy/issues/86

suoko commented on 2015-06-17 20:15

Everything works except for the chrome inspector.
I got the "Not allowed to load local resource: chrome-devtools://" error, I copy the link and open it in a new tab.
The inspector page that opens up is blank, it's not showing the safari page as expected

suoko commented on 2015-06-17 20:09

Everything works except for the chrome inspector.
I got the "Not allowed to load local resource: chrome-devtools://" error

arslonga commented on 2014-12-29 14:25

Thanks for the package! Probably usbmuxd should be added as dependency, I had an error until I installed it.