Package Details: inxi 3.1.00-1

Git Clone URL: https://aur.archlinux.org/inxi.git (read-only, click to copy)
Package Base: inxi
Description: Full featured CLI system information tool
Upstream URL: https://github.com/smxi/inxi
Licenses: GPL3
Submitter: bluewind
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 105
Popularity: 5.12
First Submitted: 2018-03-20 15:45
Last Updated: 2020-04-24 12:22

Dependencies (25)

Required by (7)

Sources (1)

Latest Comments

1 2 3 Next › Last »

cmcc commented on 2020-04-01 09:40

@merlock thanks, it works perfectly. Anyway, it would be nice to have the new version also in AUR, so we don't have to check time to time if a new upstreame release of inxi exists (and pacman helpers do not complain about newer version installed or out of date package...)

merlock commented on 2020-03-25 03:06

@cmcc...you could fix it yourself....

diff --git a/PKGBUILD b/PKGBUILD
index 244dd22..31bf62b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
 # Contributor: Florian Pritz <f-p@gmx.at>

 pkgname=inxi
-pkgver=3.0.37
-pkgrel=2
+pkgver=3.0.38
+pkgrel=1
 pkgdesc="Full featured CLI system information tool"
 arch=(any)
 url="https://github.com/smxi/inxi"
@@ -34,7 +34,7 @@ optdepends=(
   "xorg-xrandr: inxi -G single screen resolution"
 )
 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/smxi/inxi/archive/${pkgver}-1.tar.gz")
-sha256sums=('bc16d8b975a8ed064949bc8209e0c01c204c01c9046076f62709366e672bea40')
+sha256sums=('5adbbe8145e970de1d516a404554e887806d31382de81d290e71fe270183c28a')

 package() {
   cd "${pkgname}-${pkgver}-1"

cmcc commented on 2020-03-25 00:48

It's ~10 days that 3.0.38 release is out upstream. Could you syncronise also the aur package? Thanks!

ZeroDot1 commented on 2019-12-23 16:50

Please update the checksums to match the downloaded source files. Thanks!

xuiqzy commented on 2019-12-19 09:48

@FabioLolix Please update the checksums to match the downloaded source files. Thanks!

KlausDevWalker commented on 2019-12-19 00:27

@Serial download PKGBUILD and update it with updpkgsums. That will give you the update sha256sums bc16d8b975a8ed064949bc8209e0c01c204c01c9046076f62709366e672bea40.

(Or you can update the PKGBUILD when your pacman helper allows you to do so).

Serial commented on 2019-12-18 23:52

Cloning inxi files to compile ... Checking 1inxi dependencies ... Synchronizing package database ... Preparing...

Building inxi ... ==> Creating the package: inxi 3.0.37-2 (Wed 18 Dec 2019 20:50:54 -03) ==> Checking runtime dependencies ... ==> Checking build time dependencies ... ==> Getting fonts ...   -> Downloading inxi-3.0.37.tar.gz ...   % Total% Received% Xferd Average Speed ​​Time Time Time Current                                  Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 -: -: - -: -: - -: -: - 0   0 0 0 0 0 0 0 0 -: -: - -: -: - -: -: - 0 100 119 0 119 0 0 253 0 -: -: - -: -: - -: -: - 253

97 306k 97 299k 0 0 203k 0 0:00:01 0:00:01 -: -: - 203k 100 306k 100 306k 0 0 206k 0 0:00:01 0:00:01 -: -: - 620k ==> Validating source files with sha256sums ...     inxi-3.0.37.tar.gz ... FAILED ==> ERROR: One or more files failed the validity check!

danielroe commented on 2019-07-28 19:19

@ali @Ste74 Checksum looks fine to me.

Ste74 commented on 2019-07-28 09:37

@ali just for curiosity how you can say bad checksums and flagged out of date this pkg? Download from the source the pkgbuild and build with makepkg work fine without any error for me and for instance the checksums are equal than build in Manjaro.

adventurer commented on 2019-07-19 13:35

@FabioLolix : Thanks - that did the trick. I should have thought of that myself.