Package Details: intellij-idea-ue-eap 2017.3.173.2290.1-1

Git Clone URL: https://aur.archlinux.org/intellij-idea-ue-eap.git (read-only)
Package Base: intellij-idea-ue-eap
Description: Early access version of the upcoming version of Intellij Idea IDE (ultimate version)
Upstream URL: http://www.jetbrains.com/idea/
Keywords: ide java
Licenses: custom
Submitter: Kendos_Kenlen
Maintainer: artafinde
Last Packager: artafinde
Votes: 31
Popularity: 0.310083
First Submitted: 2014-09-06 20:06
Last Updated: 2017-09-14 09:31

Latest Comments

artafinde commented on 2017-08-16 13:34

@caioquirino: that's correct - my bad - I will fix when I get home later today. They are not creating their releases with scripts it's someone doing it thus depending on who does it {s}he decides the archive name. Update: fixed.

caioquirino commented on 2017-08-16 12:58

The latest version is not working:

Initializing download: https://download.jetbrains.com/idea/ideaIU-172.3757.29.tar.gz
HTTP/1.1 403 Forbidden

danielko commented on 2017-05-03 18:27

Sometimes the source url looks like ideaIU-171.4424.14.tar.gz and sometimes it looks like ideaIU-2017.1.2.tar.gz. Could you please keep both versions in PKGBUILD (perhaps commented) so it would be easy to edit PKGBUILD to install another release?

artafinde commented on 2016-12-07 10:57

Package is up to date.
Last Updated: 2016-12-07 10:52

gastonovic commented on 2016-12-07 10:55

A new build (2016.3 163.9166.20) is available.
Please update

Weby commented on 2016-08-29 10:40

Last update breaks the shortcuts in /usr/bin

Change
ln -s "${pkgdir}/opt/${pkgname}/bin/idea.sh" "${pkgdir}/usr/bin/idea-ue-eap"
to
ln -s "/opt/${pkgname}/bin/idea.sh" "${pkgdir}/usr/bin/idea-ue-eap"

to get it working again.

(This comes when you update/install from yaourt, no idea if you makepkg yourself)

ptxmac commented on 2016-05-15 08:39

eap 2016.2 have been released: https://confluence.jetbrains.com/display/IDEADEV/IDEA+2016.2+EAP

artafinde commented on 2016-04-06 07:07

@itti: you are right, I forgot to quote the variable. Thanks for pointing it out.

itti commented on 2016-04-04 07:57

Once again built the updated package with an unchanged PKGBUILD. Still the bundled JRE seems to be missing:

[itti@edi ~]$ pacman -Ql intellij-idea-ue-eap | grep jre
[itti@edi ~]$

artafinde commented on 2016-03-30 12:44

@itti: Normally one would change only the "_use_no_jdk_archive" variable to indicate that {s}he doesn't want to use the bundled JRE. If you want to keep the bundled JRE don't modify the PKGBUILD. The other variable is for me to save me from changing too many things between releases as Jetbrains seems to have two patterns in their releases (one which provide a no-jdk archive and one without).

All comments