Package Details: imcompressor 0.8.4-1

Git Clone URL: https://aur.archlinux.org/imcompressor.git (read-only, click to copy)
Package Base: imcompressor
Description: Simple & lossless image compressor.
Upstream URL: https://github.com/Huluti/ImCompressor
Licenses: GPL3
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 4
Popularity: 0.000976
First Submitted: 2019-10-10 18:14
Last Updated: 2020-11-15 15:15

Pinned Comments

yochananmarqos commented on 2019-10-27 15:19

jpegoptim is now used instead of mozjpeg. If you installed mozjpeg, please replace it with libjpeg-turbo.

Latest Comments

adrinux commented on 2020-11-15 22:19

The fix was indeed upstream. Issue and fix

Builds OK now.

adrinux commented on 2020-11-15 12:42

Build failing on manjaro stable with a failure to validate the appsteam file. Relevant part of the log:

2/3 Validate appstream file FAIL           0.62s (exit status 1)

--- command ---
12:29:21 /usr/bin/appstream-util validate data/com.github.huluti.ImCompressor.appdata.xml
--- stdout ---
data/com.github.huluti.ImCompressor.appdata.xml: FAILED:
• style-invalid         : <ul> cannot start a description [(null)]
• style-invalid         : Not enough <p> tags for a good description [0/1]
--- stderr ---
Validation of files failed

So it looks like the app description formatting needs changed. Presumably needs changed upstream?

yochananmarqos commented on 2019-10-27 15:19

jpegoptim is now used instead of mozjpeg. If you installed mozjpeg, please replace it with libjpeg-turbo.

yochananmarqos commented on 2019-10-22 14:41

Added!

huluti commented on 2019-10-22 12:00

pngquant has been added as a newer dependency to perform lossy compression.

yochananmarqos commented on 2019-10-14 18:46

Added!

huluti commented on 2019-10-14 18:32

optipng should be marked as a dependency. See https://github.com/Huluti/ImCompressor/issues/11.