Package Details: imagemagick-no-hdri 7.0.10.18-1

Git Clone URL: https://aur.archlinux.org/imagemagick-no-hdri.git (read-only, click to copy)
Package Base: imagemagick-no-hdri
Description: An image viewing/manipulation program
Upstream URL: http://www.imagemagick.org/
Licenses: custom
Conflicts: imagemagick
Provides: imagemagick
Submitter: mehcode
Maintainer: Kubax
Last Packager: Kubax
Votes: 23
Popularity: 0.000000
First Submitted: 2013-09-16 22:02
Last Updated: 2020-06-12 07:04

Dependencies (35)

Required by (848)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3

tr9sh commented on 2014-08-04 07:48

Fixed my troubles by removing the patch and updating the version to 6.8.9.6.

tr9sh commented on 2014-08-01 12:16

Any idea on howto fix[0][1]? Seems that the API libjpeg2 API broke on a newer version.

[0]: http://pastebin.com/KthHnq4t
[1]: http://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=25416

drbig commented on 2014-05-18 07:43

Scratch the below --with-perl-options silliness. It's perlbrew's evil doing. To fix: remove loading of any perlbrew crap from .bashrc or equivalent and start a shell with fresh env (e.g. bash -l) and then check output of perl '-V:install.*'. It should point to the default perl. After that makepkg should build everything as intended.

drbig commented on 2014-05-18 07:24

This may be due to me having perlbrew, though I did clean $PATH before makepkg:

With --with-perl-options="INSTALLDIRS=vendor" the perl crap get's installed at /, which not only makes it unusable, it's also sacrilege.

The obvious fix is to change that option to --with-perl-options="PREFIX=/usr/lib/perl5/vendor_perl" (which I assume the magic INSTALLDIRS=vendor was supposed to do).

Also, not related to the above, is the concern whether to provide symlinks for HDRI enabled libraries - I know it's a dirty hack, but some software needs the HDRI version (e.g. Emacs) and some can't stand the HDRI version (e.g. ruby's rmagick) - and I absolutely don't care about HDRI. Or better make it somehow that both HDRI and non HDRI version can coexist peacefully.

itlodge commented on 2014-04-04 03:08

I think the source link should be "http://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/" instead of "ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/". In some university, including mine, it's not allowed to for "ftp".

axil42 commented on 2014-03-18 20:11

@Noctua

The packages you mentioned are included in base-devel which is implied and not needed in makedepends.

https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

Anonymous comment on 2014-01-29 12:53

You may want to add automake and autoconf to the makedependencies. I for one needed to install them before this would work.

dbldub commented on 2014-01-13 22:22

I was able to install the newest version on the FTP site from 1/12/2014 by updating the version and sha1sum in PKGBUILD.

#update pkgver
pkgver=6.8.8.2

#update first line of sha1sum
sha1sums=('dc51b9d77f69bec96f398a557acb531c5af13fbc'
'e143cf9d530fabf3b58023899b5cc544ba93daec')