Package Details: image-optimizer-git c79ae12-1

Git Clone URL: https://aur.archlinux.org/image-optimizer-git.git (read-only)
Package Base: image-optimizer-git
Description: Simple losless image optimizer build for Elementary OS
Upstream URL: https://github.com/gijsgoudzwaard/image-optimizer
Keywords: compression Elementary gtk vala
Licenses: MIT
Conflicts: image-optimizer, image-optimizer-bzr
Provides: image-optimizer
Submitter: jfranco
Maintainer: None
Last Packager: jfranco
Votes: 1
Popularity: 0.000249
First Submitted: 2018-04-04 10:01
Last Updated: 2018-04-04 10:01

Latest Comments

Tio commented on 2019-01-29 16:03

I am getting this error:

Preparing... Cloning copypastegrab-git build files... Checking copypastegrab-git dependencies... Cloning cozy-audiobooks build files... Checking cozy-audiobooks dependencies... Cloning notes-up build files... Checking notes-up dependencies... Cloning spice-up-git build files... Checking spice-up-git dependencies... Cloning image-optimizer-git build files... Checking image-optimizer-git dependencies... Cloning tranqil build files... Checking tranqil dependencies... Cloning ideogram-git build files... Checking ideogram-git dependencies... Warning: cannot resolve "cmake-modules-elementary", a dependency of "image-optimizer-git" Failed to prepare transaction. Failed to prepare transaction: could not satisfy dependencies: unable to satisfy dependency 'cmake-modules-elementary' required by image-optimizer-git

Preparing... Cloning image-optimizer-git build files... Checking image-optimizer-git dependencies... Cloning cmake-modules-elementary-git build files... Checking cmake-modules-elementary-git dependencies... Cloning ideogram-git build files... Checking ideogram-git dependencies... Cloning copypastegrab-git build files... Checking copypastegrab-git dependencies... Cloning cozy-audiobooks build files... Checking cozy-audiobooks dependencies... Cloning tranqil build files... Checking tranqil dependencies... Cloning notes-up build files... Checking notes-up dependencies... Cloning spice-up-git build files... Checking spice-up-git dependencies... Resolving dependencies... Checking inter-conflicts... Downloading gst-python (1.14.4-1-x86_64)... Downloading gcolor3 (2.3.1-2-x86_64)... Downloading gpick (0.2.6rc1-5-x86_64)... Downloading optipng (0.7.7-1-x86_64)... Downloading jpegoptim (1.4.6-1-x86_64)... Downloading python-mutagen (1.42.0-1-any)... Checking keyring... Checking integrity... Loading packages files... Checking file conflicts... Checking available disk space... Installing gcolor3 (2.3.1-2)... Installing gpick (0.2.6rc1-5)... Installing optipng (0.7.7-1)... Installing jpegoptim (1.4.6-1)... Installing gst-python (1.14.4-1)... Installing python-mutagen (1.42.0-1)... Running post-transaction hooks... Updating icon theme caches... Arming ConditionNeedsUpdate... Updating the desktop file MIME type cache... Building cmake-modules-elementary-git... ==> Making package: cmake-modules-elementary-git latest-1 (mar 29 ene 2019 16:59:51 CET) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Cloning cmake-modules-elementary git repo... Cloning into bare repository '/tmp/pamac-build/cmake-modules-elementary-git/cmake-modules-elementary'... ==> Validating source files with sha256sums... cmake-modules-elementary ... Skipped ==> Removing existing $srcdir/ directory... ==> Extracting sources... -> Creating working copy of cmake-modules-elementary git repo... Cloning into 'cmake-modules-elementary'... done. Switched to a new branch 'makepkg' ==> Starting prepare()... ==> Starting pkgver()... ==> Updated version: cmake-modules-elementary-git r37.319ec53-1 ==> Starting build()... -- The C compiler identification is GNU 8.2.1 -- The CXX compiler identification is GNU 8.2.1 -- Check for working C compiler: /usr/bin/cc -- Check for working C compiler: /usr/bin/cc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Detecting C compile features -- Detecting C compile features - done -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done -- Configuring done -- Generating done -- Build files have been written to: /tmp/pamac-build/cmake-modules-elementary-git/src/cmake-modules-elementary/build ==> Entering fakeroot environment... ==> Starting package()... Install the project... -- Install configuration: "Release" -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/FindGirCompiler.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/FindVala.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/GObjectIntrospectionMacros.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/GResource.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/GSettings.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/Tests.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/Translations.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/Uninstall.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/ValaPrecompile.cmake -- Installing: /tmp/pamac-build/cmake-modules-elementary-git/pkg/cmake-modules-elementary-git/usr/share/cmake-3.13/Modules/ValaVersion.cmake ==> Tidying install... -> Removing libtool files... -> Purging unwanted files... -> Removing static library files... -> Stripping unneeded symbols from binaries and libraries... -> Compressing man and info pages... ==> Checking for packaging issues... ==> Creating package "cmake-modules-elementary-git"... -> Generating .PKGINFO file... -> Generating .BUILDINFO file... -> Generating .MTREE file... -> Compressing package... ==> Leaving fakeroot environment. ==> Finished making: cmake-modules-elementary-git r37.319ec53-1 (mar 29 ene 2019 16:59:56 CET) ==> Cleaning up...

Resolving dependencies... Checking inter-conflicts... Checking keyring... Checking integrity... Loading packages files... Checking file conflicts... Checking available disk space... Installing cmake-modules-elementary-git (r37.319ec53-1)... Building image-optimizer-git... ==> Making package: image-optimizer-git c79ae12-1 (mar 29 ene 2019 16:59:57 CET) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Cloning Image-Optimizer git repo... Cloning into bare repository '/tmp/pamac-build/image-optimizer-git/Image-Optimizer'... ==> Validating source files with md5sums... Image-Optimizer ... Skipped ==> Removing existing $srcdir/ directory... ==> Extracting sources... -> Creating working copy of Image-Optimizer git repo... Cloning into 'Image-Optimizer'... done. ==> Starting pkgver()... ==> Updated version: image-optimizer-git 7eada83-1 ==> Starting build()... CMake Error: The source directory "/tmp/pamac-build/image-optimizer-git/src/Image-Optimizer" does not appear to contain CMakeLists.txt. Specify --help for usage, or press the help button on the CMake GUI. ==> ERROR: A failure occurred in build(). Aborting...