Package Details: icesl 2.4.2-1

Git Clone URL: https://aur.archlinux.org/icesl.git (read-only, click to copy)
Package Base: icesl
Description: A GPU accelerated modeler and slicer for 3D printing
Upstream URL: https://icesl.loria.fr
Licenses: custom
Submitter: arnottcr
Maintainer: arnottcr
Last Packager: arnottcr
Votes: 4
Popularity: 0.000000
First Submitted: 2017-11-14 09:17
Last Updated: 2021-11-28 02:37

Latest Comments

philb38 commented on 2021-11-30 16:37

Been able to run IceSL 2.4.2 setting the LD_LIBRARY_PATH to catch the libluabind.so library in /usr/share/icesl/bin/...

philb38 commented on 2021-11-30 15:44

Hello, I just updated to 2.4.2 (thank you for this), but when trying to run icesl, I get "icesl: error while loading shared libraries: libluabind.so: cannot open shared object file: No such file or directory" May it be a missing dependency?

philb38 commented on 2021-11-24 14:30

Hello, IceSL 2.4.2 is now available. Any chance this package gets updated to last version please?

bartus commented on 2020-12-01 17:57

_id should be 38374, current one is redirected to default download witch is windows x64 installer.

arnottcr commented on 2020-06-12 20:49

jhbruhn: 2.3.5 is still in beta, https://gforge.inria.fr/frs/?group_id=4731, bump when it hits GA.

arnottcr commented on 2018-10-04 04:20

This was a known limitation; icesl did not play well with mesa, and I had to use a dedicated graphics card.

This appears to have changed with the recent 2.2.x release; can you retest?

gauoni commented on 2018-09-30 09:49

Hi,

when i start Icesl in terminal I have this

[code] 0:2(10): error: GLSL 4.20 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, and 3.00 ES

[FATAL]

* GLSL shader failed to compile (vertex) * 0:2(10): error: GLSL 4.20 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, and 3.00 ES [/code]

arnottcr commented on 2018-03-24 18:53

yeah, for some reason his file server only gives out one file regardless of the path specified. this, as well as the new version has been added in the recent commit. let me know if you see any more issues.

Cebtenzzre commented on 2018-03-23 02:14

Since the last update, this has been failing to install on my system. (I know, I'm really late, but I hadn't bothered to investigate before.) It seems as though the provided "icesl2.1.11-amd64.deb" is not even a Debian .deb package; rather a ZIP file containing an extracted copy of the program. Somehow makepkg extracts the mis-named .deb file anyway, but the PKGBUILD fails, as the standard control.tar.gz and data.tar.gz are not present (because it's not a valid Debian package). I have no idea how this happened, but you should probably look into it. :P

programacho commented on 2018-01-25 11:37

After installation:

ls -al /usr/bin/icesl lrwxrwxrwx 1 root root 77 25.01.2018 12:30 /usr/bin/icesl -> /tmp/yaourt-tmp-joseluis/aur-icesl/pkg/icesl/usr/share/icesl/bin/IceSL-slicer