Package Details: iced-coffee-script 108.0.11-1

Git Clone URL: https://aur.archlinux.org/iced-coffee-script.git (read-only)
Package Base: iced-coffee-script
Description: CoffeeScript with await/defer syntax added
Upstream URL: https://maxtaco.github.io/coffee-script/
Submitter: oconnor663
Maintainer: oconnor663
Last Packager: oconnor663
Votes: 1
Popularity: 0.000000
First Submitted: 2016-03-16 15:39
Last Updated: 2016-06-22 14:33

Latest Comments

Eremiell commented on 2017-04-09 20:16

A separate package might make sense for now I guess, similar to say how they roll from perl5 to perl6.

perl5 is still stable, so perl is perl5 and perl6 is perl6. Once perl6 becomes stable, perl will become perl6 and perl5 will be packaged as perl5.

Guess that's a reasonable scheme?

oconnor663 commented on 2017-04-07 14:51

@Eremiell yes, iced-coffee-script-3 is a pretty major version bump, which emits ES6 instead of ES5. It might make sense to upgrade to it after it gets more mature (and after ES6 support is more widespread), or maybe to create a separate package before then?

Eremiell commented on 2017-04-06 20:20

I flagged this package and after some research unflagged it again, sorry for being a bit rushed on that.

There is a new version at https://github.com/maxtaco/coffee-script/releases/tag/v111.1.1 , but I saw, you take sources from npm and not github.

That version is on npm at https://www.npmjs.com/package/iced-coffee-script-3 and is flagged as alpha.

As I'm just starting to mess with it and am no expert on it, I'll keep it here for you to decide, if it should be updated or not.

oconnor663 commented on 2016-06-22 14:34

@mpcsh added npm in makedepends. Thanks for catching that.

mpcsh commented on 2016-06-22 04:36

Minor quibble - it should depend on both nodejs and npm, since nodejs doesn't depend on npm. If the user doesn't have npm installed separately the build fails with "npm: command not found" on line 22 of the PKGBUILD.