Package Details: icecream 1.3-1

Git Clone URL: https://aur.archlinux.org/icecream.git (read-only)
Package Base: icecream
Description: takes compile jobs from your build and distributes it to remote machines allowing a parallel build on several machines.
Upstream URL: http://en.opensuse.org/Icecream
Licenses: GPL2
Conflicts: icecream-git
Provides: icecream
Submitter: uwolfer
Maintainer: bwidawsk
Last Packager: bwidawsk
Votes: 33
Popularity: 0.453398
First Submitted: 2006-10-11 20:48
Last Updated: 2019-09-25 20:08

Latest Comments

« First ‹ Previous 1 2 3 4 5

Anonymous comment on 2011-05-04 14:26

The same fix was also done independently and ended up being commited upstream -- http://websvn.kde.org/?view=revision&revision=1230353

I recommend updating the package here.

Anonymous comment on 2011-05-03 02:07

The following patch should fix the issue with gcc 4.6: http://paste.kde.org/48373/ (remember to rm -fr /tmp/icecc* and then restart the icecream daemon after that).

I'm still wondering whether this fix should be committed upstream, or if gcc is at fault for relying on a file which only exists in /usr/lib/gcc/<arch>/4.6.0.

hugo commented on 2011-04-28 17:45

It doesn't work with g++ 4.6, I always get the error:

g++: fatal error: -fuse-linker-plugin, but liblto_plugin.so not found

the liblto_plugin.so isn't in the gcc tarball created by icecc.

lucasdemarchi commented on 2010-06-18 14:09

I confirm this problem occurs. Worth noting that this bug (that already existed before) was exposed by the update on glibc from 2.11 to 2.12

Anonymous comment on 2010-06-17 15:17

Until a new release is made, the PKGBUILD should be modified with the following patch from upstream trunk: http://websvn.kde.org/trunk/icecream/client/icecc-create-env?r1=926473&r2=1131079

Otherwise, icecc will not be able to send jobs to other clients.