Package Details: icecat 78.10.0-2

Git Clone URL: https://aur.archlinux.org/icecat.git (read-only, click to copy)
Package Base: icecat
Description: GNU version of the Firefox browser.
Upstream URL: http://www.gnu.org/software/gnuzilla/
Keywords: browser esr gnuzilla web
Licenses: GPL, MPL, LGPL
Submitter: None
Maintainer: figue (figuepluto, jfigueras)
Last Packager: figue
Votes: 228
Popularity: 4.12
First Submitted: 2007-12-09 10:12
Last Updated: 2021-04-21 14:45

Dependencies (39)

Required by (0)

Sources (5)

Pinned Comments

cysp74 commented on 2021-02-27 18:53

I've made some checks and lowered "security.sandbox.content.level" to 1 (default is 4). Perhaps a bit better approach, instead of disabling completely sandbox.

figue commented on 2020-09-29 22:37

@Terrorizer patch process can take a long time, depending on your machine capacity.

Good news is that IceCat was added to Chaotic repo recently:

https://lonewolf.pedrohlc.com/chaotic-aur/

cb474 commented on 2010-09-19 20:51

Yeah, I know they've done that in the past, when there was a release to change one setting in about:config, Gnuzilla didn't upgrade Icecat. But Firefox 3.6.10 was released because users were having issues with it crashing on startup (in Windows, OS X, and Linux). Seems more significant. There may only be a couple lines of code different, but that doesn't mean they don't resolve a real problem. Anyway, I'm not having the crash problem. I was just surprised Gnuzilla wasn't upgrading this time.

jackoneill commented on 2010-09-19 11:39

@cb474:
They probably think the differences between 3.6.9 and 3.6.10 are insignificant. You can see for yourself by downloading these two:

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.9/source/firefox-3.6.9.source.tar.bz2
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.10/source/firefox-3.6.10.source.tar.bz2

Put each in its own folder, extract, then run `diff -r firefox369/mozilla-1.9.2 firefox3610/mozilla-1.9.2`
There's not much to see, though.

cb474 commented on 2010-09-19 08:53

Yes, I meant on the Gnuzilla site. Why is Gnuzilla not upgrading to 3.6.10. That was my question.

wonder commented on 2010-09-18 20:26

because there is no 3.6.10 version?

look in the ftp tree

cb474 commented on 2010-09-18 20:25

Is there a reason why Icecat is not being upgraded to 3.6.10?

jackoneill commented on 2010-09-18 11:04

I just compiled icecat with xulrunner 1.9.2.10 and it works.

haawda commented on 2010-09-18 01:25

Builds fine with latest xulrunner and autoconf.

jackoneill commented on 2010-09-13 09:49

I see.
Thanks.

figue commented on 2010-09-13 09:46

@cantabile Sorry, I've forgot to comment. New release use /usr/lib/icecat-3.6 for instalation path because locale packages use /usr/lib/icecat symlink to install in correct place, though IceCat use /usr/lib/icecat-3.6.X, so those directories don't remove on every upgrade. With this method, all was clean. post_install() has a suggestion to remove those old directories.

If you don't use any locale, you can ignore this upgrade.

jackoneill commented on 2010-09-13 09:24

Sorry, forgot to specify:
from 3.6.9-1 to 3.6.9-2