Package Details: icecat 78.10.0-2

Git Clone URL: https://aur.archlinux.org/icecat.git (read-only, click to copy)
Package Base: icecat
Description: GNU version of the Firefox browser.
Upstream URL: http://www.gnu.org/software/gnuzilla/
Keywords: browser esr gnuzilla web
Licenses: GPL, MPL, LGPL
Submitter: None
Maintainer: figue (figuepluto, jfigueras)
Last Packager: figue
Votes: 228
Popularity: 4.11
First Submitted: 2007-12-09 10:12
Last Updated: 2021-04-21 14:45

Dependencies (39)

Required by (0)

Sources (5)

Pinned Comments

cysp74 commented on 2021-02-27 18:53

I've made some checks and lowered "security.sandbox.content.level" to 1 (default is 4). Perhaps a bit better approach, instead of disabling completely sandbox.

figue commented on 2020-09-29 22:37

@Terrorizer patch process can take a long time, depending on your machine capacity.

Good news is that IceCat was added to Chaotic repo recently:

https://lonewolf.pedrohlc.com/chaotic-aur/

Latest Comments

« First ‹ Previous ... 58 59 60 61 62 63 64 65 66 67 68 ... Next › Last »

Ravenman commented on 2010-10-20 22:45

Please update: http://www.archlinux.org/news/python-is-now-python-3/

wonder commented on 2010-10-19 18:43

use this patch: http://repos.archlinux.org/wsvn/packages/firefox/trunk/python2.7.patch

jackoneill commented on 2010-10-19 18:39

Please change 'python' to 'python2' in the makedeps, because the package called 'python' now provides version 3.1.2 and it throws this error while building icecat:
/usr/bin/python ../toolkit/xre/make-platformini.py --print-buildid > buildid
File "../toolkit/xre/make-platformini.py", line 17
print datetime.now().strftime('%Y%m%d%H%M%S')
^
SyntaxError: invalid syntax

jackoneill commented on 2010-10-03 11:51

That's like 2 changes, what took them so long...

figue commented on 2010-10-02 19:24

3.6.10 is up.

Changelog:
This new version includes all changes made upstream in Firefox 3.6.10.

Now the privacy extension gives an alert everytime a bookmark containing
javascript code is stored.

Now, by default, HTML5 local storage is disabled. If you desire it,
then it must be manually enabled.

Ravenman commented on 2010-09-22 22:54

@captainhaggy: Thank you. It worked for me.

Anonymous comment on 2010-09-22 16:42

If the question appears
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
Say yes, edit the line you see aboth and enter a > at the position, where you can see it here in the comment.

It lookls like this
depends=("xulrunner=${_xulver}" 'desktop-file-utils')

and has to be changed to
depends=("xulrunner>=${_xulver}" 'desktop-file-utils')

Now icecat is able to install again.

jackoneill commented on 2010-09-22 13:24

@figue:
Thanks :)
There are indeed no file conflicts between firefox-beta and icecat.

figue commented on 2010-09-22 13:11

@cantabile there's no reason, I think this comes from an old version. I'll remove in the next release.

jackoneill commented on 2010-09-22 12:28

Is there some very good reason for icecat to provide firefox? I want to install firefox-beta, but pacman won't let me, because it conflicts with firefox, and icecat provides firefox. There should be no file conflicts between the two, after all firefox and icecat can live on the same system just fine.