Package Details: icecat-bin 60.7.0-2

Git Clone URL: https://aur.archlinux.org/icecat-bin.git (read-only)
Package Base: icecat-bin
Description: Binary build of the GNU version of the Mozilla Firefox browser
Upstream URL: http://www.gnu.org/software/gnuzilla/
Keywords: browser gecko web
Licenses: GPL, MPL, LGPL
Conflicts: icecat
Provides: icecat
Replaces: icecat
Submitter: jfigueras
Maintainer: figue (figuepluto, jfigueras)
Last Packager: figuepluto
Votes: 39
Popularity: 1.402679
First Submitted: 2016-01-03 12:11
Last Updated: 2019-06-03 20:06

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

figue commented on 2017-06-19 19:38

@xxterry1xx forgot to change. Fixed. Thanks!

Anonymous comment on 2017-06-18 23:45

This can only open in gtk3 as it says libgtk-3.so is missing, the dependency gtk2 should be changed to gtk3.

Thanks for the package.

figue commented on 2016-06-29 09:24

@Hund I don't know why you need to change those permissions, it has 755 in my computer:

figue@DESA2338> ls -l /usr/lib/icecat
-rwxr-xr-x 1 root root 113800 jun 26 23:58 /usr/lib/icecat/icecat

I have double checked... pacman set this permission upgrading/downgrading, or replacing icecat-bin package with icecat (compiled).

Hund commented on 2016-06-28 16:05

Also, any particular reason I have to make the file /usr/lib/icecat/icecat executable myself every time I update IceCat?

Hund commented on 2016-06-28 16:00

@figue It was already added. But I solved it by removing the whole icecat-bin folder and redoing it from scratch. I don't know why I didn't think of that before.

Hund commented on 2016-06-28 16:00

@figue It was already added. But I solved it by removing the whole icecat-bin folder and redoing it from scratch. I don't know why I didn't think of that before.

figue commented on 2016-06-28 15:37

@Hund you should probably add Ruben Rodriguez's signature (official IceCat developer) to your keyring:

gpg --recv-key 3C76EED7D7E04784

More info: https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

Hund commented on 2016-06-28 10:58

==> Verifying source file signatures with gpg...
icecat-38.8.0.en-US.linux-x86_64.tar.bz2 ... FAILED (bad signature from public key 3C76EED7D7E04784)
==> ERROR: One or more PGP signatures could not be verified!

What to do?

figue commented on 2016-06-26 21:55

@ilya-fedin sorry I haven't see your last comment.

Currently I'm not interested in maintain a gtk2 package, but taking a look into firefox-gtk2 in AUR, it seems that you only need to add "ac_add_options --enable-default-toolkit=cairo-gtk2" to mozconfig in order to build a gtk2 package. I can do this for you if you need it and you can't/don't know how to do it, but please consider the chance to make it yourself. It's not complicated :)

ilya-fedin commented on 2016-05-26 21:36

figue, the matter is that I want to come completely to IceCat (to use the favourite browser one, and to use his modification from GNU - even better :)), but I don't love GTK3, and Firefox on him. My question was in whether you will make a icecat-gtk2/icecat-gtk2-bin package in case of transition of IceCat to GTK3, as well as Firefox? Or can be at you there is information that someone another will make such package?