Package Details: ice-ssb 6.0.3-1

Git Clone URL: https://aur.archlinux.org/ice-ssb.git (read-only)
Package Base: ice-ssb
Description: a simple Site Specific Browser for Firefox, Chromium and Google Chrome from "Peppermint OS" Project
Upstream URL: https://github.com/peppermintos/ice
Keywords: ice peppermint peppermintos
Licenses: GPL2
Submitter: benneti
Maintainer: ivanmlerner
Last Packager: ivanmlerner
Votes: 18
Popularity: 0.148649
First Submitted: 2015-08-16 09:40
Last Updated: 2019-05-29 19:48

Latest Comments

1 2 Next › Last »

ivanmlerner commented on 2019-05-29 19:59

This problem is fixed in the new version.

dirtyninja commented on 2019-04-13 16:52

@michaldybczak sounds like you are having an issue with the encoding?

I am also getting: /usr/bin/ice:721: DeprecationWarning: Gtk.Button.new_from_stock is deprecated apply_button = Gtk.Button.new_from_stock(Gtk.STOCK_APPLY)

but it stills works for me.

What is your locale.conf?

michaldybczak commented on 2019-04-04 21:53

The new version isn't working:

/usr/bin/ice:721: DeprecationWarning: Gtk.Button.new_from_stock is deprecated apply_button = Gtk.Button.new_from_stock(Gtk.STOCK_APPLY) Traceback (most recent call last): File "/usr/bin/ice", line 818, in <module> window = Ice() File "/usr/bin/ice", line 759, in init details = get_details(a) File "/usr/bin/ice", line 72, in get_details for line in a: File "/usr/lib/python3.7/codecs.py", line 322, in decode (result, consumed) = self._buffer_decode(data, self.errors, final) UnicodeDecodeError: 'utf-8' codec can't decode byte 0x89 in position 0: invalid start byte

I downgraded the package but it still has an issue and doesn't start so I guess the new gtk version is conflicting with it so I may report it upstream.

ivanmlerner commented on 2018-09-14 14:09

Do you mean you have both stable and snapshot of vivaldi or ice-ssb? It greys out options that are not installed for me. It should work, since there haven't been any major changes to the software since I took over the package, and the previous maintainer was the developer itself. Have you tested it?

mthomas commented on 2018-09-07 18:35

I know it's an option in the window - does this work with vivaldi? I have both the stable and snapshot installed, but vivaldi is greyed out as an option.

benneti commented on 2018-05-14 15:23

Fine with me, thank you for taking over. I definitly think it is doable, as this was my first PKGBUILD

ivanmlerner commented on 2018-05-14 14:32

Hi, I've been wanting to get started on packaging for the aur, I'd be interested in adopting it, and will be using ice myself. It would be my first time though, do you think it is doable? The PKGBUILD seems fairly straight forward.

benneti commented on 2017-08-11 13:06

I added the dependency.
If anyone is interested in adopting the PKGBUILD let me know,
as I do not use ice anymore and thus the package does not get any real testing...

JollyRoo commented on 2017-08-09 02:38

I think ice requires python-lxml in order to fetch the icons from the websites. I spent some time trying to get the icons to work on my pc, and finally got it working after installing python-lxml. It is an optional dependency of python-beautifulsoup4, but it seems to be required by ice:

soup = BeautifulSoup(markup, "lxml")

Can you add that as a dependency, or optional dependency?

benneti commented on 2017-08-08 07:41

The problem is that the packagebuild tries to symlink these to the standard archlinux locations of the programms.
You can just comment the lines in PKGBUILD out and check whether it works then