Package Details: i3lock-color 2.13.c.2-1

Git Clone URL: https://aur.archlinux.org/i3lock-color.git (read-only, click to copy)
Package Base: i3lock-color
Description: An improved screenlocker based upon XCB and PAM with color configuration support
Upstream URL: https://github.com/Raymo111/i3lock-color
Keywords: i3 i3lock i3wm lock
Licenses: MIT
Conflicts: i3lock, i3lock-color-git
Provides: i3lock, i3lock-color
Submitter: Alad
Maintainer: Raymo111 (wilssonmartee)
Last Packager: wilssonmartee
Votes: 19
Popularity: 3.34
First Submitted: 2020-10-18 21:53
Last Updated: 2021-02-16 00:38

Required by (49)

Sources (1)

Latest Comments

1 2 Next › Last »

Raymo111 commented on 2021-02-16 00:39

Thanks @wilssonmartee!

dreeg_ocedam commented on 2021-01-03 18:01

@wilssonmartee indeed, my bad. It's weird that I didn't have it installed on this computer. Sorry to have bothered you.

wilssonmartee commented on 2021-01-03 17:54

@dreeg_oced automake is part of base-devel, to start using AUR you need to have all the packages belonging to this group already installed so it would not be necessary to include it in makedepend. Source: https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

dreeg_ocedam commented on 2021-01-03 17:28

Indeed, after searching for a bit, it seems that automake was the missing build dependency. It should probably be added in the PKGBUILD.

Raymo111 commented on 2021-01-02 17:27

@dreeg_ocedam do you have autoconf installed? You should install the whole build-devel group to build packages.

dreeg_ocedam commented on 2021-01-01 19:49

Hello, since the last update, I get the following error in the build function:

Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 274.
autoreconf: error: aclocal failed with exit status: 2

Raymo111 commented on 2020-12-23 20:07

@tortenairbag You need to install autoconf, which is in base-devel, before building AUR packages.

tortenairbag commented on 2020-12-23 11:34

Hi everyone, I get an error updating this package from 2.12.c.5-1 to 2.13.c.1-1

~/.cache/yay/i3lock-color/PKGBUILD: line 21: autoreconf: command not found

The package "autoconf" is missing as build dependency

Raymo111 commented on 2020-11-28 19:27

Thanks! Added you as co-maintainer.

wilssonmartee commented on 2020-11-28 18:49

@Raymo111 I have no idea, you can adopt it now