Package Details: i3-gaps-next-git 4.18.3.r255.g9688a894-1

Git Clone URL: (read-only, click to copy)
Package Base: i3-gaps-next-git
Description: A fork of i3wm tiling window manager (development branch) with more features, including gaps
Upstream URL:
Keywords: gaps i3
Licenses: BSD
Groups: i3-vcs
Conflicts: i3-gaps, i3-gaps-git, i3-git, i3-wm, i3bar, i3bar-git
Provides: i3-wm
Submitter: bandali
Maintainer: Airblader
Last Packager: Airblader
Votes: 128
Popularity: 0.74
First Submitted: 2015-01-04 04:40
Last Updated: 2020-10-20 08:12

Dependencies (22)

Required by (43)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

madscience commented on 2019-01-29 15:24

That worked perfectly, thanks!

Airblader commented on 2019-01-29 07:49

@madscience I've changed the pkgver now according to the guidelines[1]. Probably one reinstall is necessary to update the local version, though. Let me know if you have issues still. Thanks!


Airblader commented on 2019-01-29 07:35

@madscience That's a side effect of how pkgver is calculated and the fact that there has been a 4.16.1 patch release. That's very unfortunate. If someone has an idea of how to change the pkgver to avoid this I'd be happy to incorporate it... I'm using git describe right now which I was hoping wouldn't have such issues. Possibly it'd be enough to remove the replacement of dashes with dots?

madscience commented on 2019-01-28 23:55

I updated to the latest version of the package and I keep getting prompted to update by my AUR helper (pikaur). Is there an issue with the version number in the pkgbuild? or is it my aur helper?

:: AUR package will be installed: i3-gaps-next-git -> 4.16.56.g56ea3afe-1

madscience commented on 2019-01-06 04:47

I just got a pango update,

pango 1.43.0-1 -> 1:1.42.4-1

which looks like the pango update was reverted, and the problem is resolved

Airblader commented on 2019-01-05 22:28

Thanks everyone. Maybe the issue is that this package doesn't explicitly depend on glib2 or something. Could someone try adding the dependency explicitly to PKGBUILD and seeing if it works then (after upgrading pango again, of course)?

wjeng commented on 2019-01-05 21:18

Downgrading pango worked for me too.

madscience commented on 2019-01-05 18:35

Downgrading pango allowed the build to proceed. I tried updating pango again after building and it seems OK for now, so this is a temporary workaround.

rhssk commented on 2019-01-05 18:30

Same problem, downgrading pango (1.43.0-1 -> 1.42.4-1) helped.

philm commented on 2019-01-05 15:00

Can confirm, have the same error while building