Package Details: i2pd-git 2.38.0.r111.ga7175427-1

Git Clone URL: https://aur.archlinux.org/i2pd-git.git (read-only, click to copy)
Package Base: i2pd-git
Description: A full-featured C++ implementation of the I2P router (git version)
Upstream URL: https://i2pd.website/
Licenses: BSD
Conflicts: i2pd
Provides: i2p-router, i2pd
Submitter: robertfoster
Maintainer: dbermond
Last Packager: dbermond
Votes: 11
Popularity: 0.003319
First Submitted: 2014-08-20 15:08
Last Updated: 2021-07-04 12:04

Latest Comments

1 2 3 4 Next › Last »

dbermond commented on 2021-03-11 20:52

@keren_sky Patches updated.

keren_sky commented on 2021-03-11 15:11

Hi, build is failing w/ the following error: -> Creating working copy of i2pd git repo... Cloning into 'i2pd'... done. Switched to a new branch 'makepkg' ==> Starting prepare()... >patching file tests/Makefile

patching file contrib/i2pd.conf patching file contrib/i2pd.service Hunk #1 FAILED at 11. 1 out of 1 hunk FAILED -- saving rejects to file contrib/i2pd.service.rej ==> ERROR: A failure occurred in prepare(). Aborting...

DDoSolitary commented on 2020-05-24 04:59

Build failing:

rm: cannot remove '/home/builder/build/i2pd-git/pkg/i2pd-git/usr/src': No such file or directory
rm: cannot remove '/home/builder/build/i2pd-git/pkg/i2pd-git/usr/LICENSE': No such file or directory

It seems that a recent commit removed installation of these files.

DDoSolitary commented on 2019-06-08 17:57

@redfish But the pkgbuild specifies the master branch directly in the URL

redfish commented on 2019-06-08 17:47

@phake: openssl is the default branch on github, so it is already the one cloned by this PKGBUILD.

phake commented on 2019-06-08 08:28

The main branch on the SVN is now openssl. Please change the link to git+https://github.com/PurpleI2P/i2pd#branch=openssl. NTCP1 is already disabled by default. In openssl works NTCP2.

redfish commented on 2018-08-03 02:09

Could you please add provides=("${pkgname%%-git}=${pkgver}") so that this package satisfies the dependency of packages that depend on i2pd. I tested this one-line patch to the i2pd-git PKGBUILD: it fixes the build of xd-torrent package. Btw, some of the older suggestions might be good to merge, too. Thanks.

Jikstra commented on 2018-07-03 17:09

In case you get this error:

$ makepkg -si
==> FEHLER: conflicts enthält ungültige Zeichen: '${%%}'

Change line 20 to conflicts=("${pkgname%%-git}")

redfish commented on 2018-03-05 23:50

Since PR#1142 was merged, please remove the tmpfiles stuff on Line 42 in PKGBUILD and Line 14 in .install. Thanks! Btw, also, do not remove the user on uninstall in .install (the policy is to not remove user, to prevent orphaned objects in the file system).

DDoSolitary commented on 2017-10-24 08:08

Please add git to makedepends.
https://wiki.archlinux.org/index.php/VCS_package_guidelines#Guidelines