Package Details: hyper-git 3.1.0.canary.4.r783.gbb5635cb-1

Git Clone URL: https://aur.archlinux.org/hyper-git.git (read-only, click to copy)
Package Base: hyper-git
Description: A terminal built on web technologies
Upstream URL: https://hyper.is/
Licenses: MIT
Conflicts: hyper
Provides: hyper
Submitter: ahrs
Maintainer: bet4it
Last Packager: bet4it
Votes: 0
Popularity: 0.000000
First Submitted: 2017-10-16 20:28
Last Updated: 2021-03-19 04:47

Latest Comments

simona commented on 2021-02-07 10:53

I have a problem upgrading this pkg with yay / paru.
My -Syu upgrade find every time a new upgrade and avery time upgrade:
aur/hyper-git v3.1.0.canary.3.r582.g712a1908-1 -> 3.1.0.canary.4.r48.gb0002bbe-1
If I start yay/pary -Syu after upgrade it do
aur/hyper-git v3.1.0.canary.3.r582.g712a1908-1 -> 3.1.0.canary.4.r48.gb0002bbe-1
again and again...
I must set 'IgnorePkg = hyper-git' to avoid problem.

yochananmarqos commented on 2020-07-04 18:37

Fixed pkgver() function:

pkgver() {
  cd "${pkgname}"
  git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/canary.3/canary.4/;s/-/./g'
}
3.1.0.canary.4.r203.gdab6e06d

skyjack commented on 2020-04-11 18:17

Seems this is building a different version than the pkgver specifies in the PKGBUILD. It builds "v3.1.0.canary.3.r40.gf730d840-1" rather than the 3.1.0.canary.4.r48.gb0002bbe-1 described. Appears that the version that is being built from the git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' doesn't match pkgver

qguv commented on 2018-02-11 20:13

Appears to require cross-env as a build dependency. It fails on build without it. Running:

# npm install -g cross-env

before installing the package fixed it.

ahrs commented on 2017-10-16 20:33

This builds from the canary branch by default. You can export the HYPER_BRANCH variable to build from another branch. E.g, to build from master `export HYPER_BRANCH=master`.