Package Details: hunspell-gl 2:18.07-2

Git Clone URL: https://aur.archlinux.org/hunspell-gl.git (read-only, click to copy)
Package Base: hunspell-gl
Description: Galician hunspell dictionaries. RAG/ILG normative
Upstream URL: https://github.com/meixome/hunspell-gl
Licenses: GPL3
Conflicts: hunspell-gl
Provides: hunspell-gl
Submitter: zielhno
Maintainer: zielhno
Last Packager: zielhno
Votes: 2
Popularity: 0.86
First Submitted: 2015-09-22 01:50
Last Updated: 2019-08-31 13:28

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

Gallaecio commented on 2020-08-03 04:26

Shouldn’t this package, given the name, use the default build parameters? I recall maintaining a “comunidade” version in the past with this set of parameters, but I believe that was called ”hunspell-gl-comunidade”.

frandieguez commented on 2020-08-02 18:08

There is a new version of the package, here you have a patch to update the PKGBUILD

diff --git i/PKGBUILD w/PKGBUILD
index d983770..32b8bb7 100644
--- i/PKGBUILD
+++ w/PKGBUILD
@@ -1,20 +1,20 @@
 pkgname=hunspell-gl
-pkgver=18.07
-pkgrel=2
+pkgver=20.08
+pkgrel=1
 epoch=2
 pkgdesc="Galician hunspell dictionaries. RAG/ILG normative"
 arch=(any)
-url="https://github.com/meixome/hunspell-gl"
+url="https://gitlab.com/proxecto-trasno/hunspell-gl"
 license=('GPL3')
 optdepends=('hunspell:  the spell checking libraries and apps')
 makedepends=('scons' 'python-pyicu')
 provides=($pkgname)
 conflicts=($pkgname)
-source=("${pkgname}.tar.gz::https://github.com/meixome/hunspell-gl/archive/${pkgver}.tar.gz")
-md5sums=('f997f11bcfc0eefd923af03d71c107ad')
+source=("${pkgname}.tar.bz2::https://gitlab.com/proxecto-trasno/hunspell-gl/-/archive/${pkgver}/hunspell-gl-${pkgver}.tar.bz2")
+md5sums=('9355f8752e2ae5a3ce7b8dd574f2dced')

 prepare() {
-  mkdir -p "$srcdir/$pkgname" && tar xfz "$pkgname.tar.gz" -C "$pkgname" --strip-components 1
+  mkdir -p "$srcdir/$pkgname" && tar xfz "$pkgname.tar.bz2" -C "$pkgname" --strip-components 1
 }

zielhno commented on 2019-08-31 13:31

Thanks for the heads up! It should work now.

frandieguez commented on 2019-08-25 23:43

I think that a simple fix for the issue is to replace python2-pyicu with python-pyicu

frandieguez commented on 2019-08-25 23:34

I can't install this package due to unmeet dependencies:

```[I] ➜ yay hunspell-gl 1 aur/hunspell-gl 2:18.07-1 (+1 0.00%) Galician hunspell dictionaries. RAG/ILG normative ==> Packages to install (eg: 1 2 3, 1-3 or ^4) ==> 1 :: Checking for conflicts... :: Checking for inner conflicts... [Aur: 1] hunspell-gl-2:18.07-1

1 hunspell-gl (Build Files Exist) ==> Packages to cleanBuild? ==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4) ==> :: PKGBUILD up to date, Skipping (1/1): hunspell-gl 1 hunspell-gl (Build Files Exist) ==> Diffs to show? ==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4) ==> :: Parsing SRCINFO (1/1): hunspell-gl ==> Making package: hunspell-gl 2:18.07-1 (Mon 26 Aug 2019 01:33:16 AM CEST) ==> Retrieving sources... -> Found hunspell-gl.tar.gz ==> Validating source files with md5sums... hunspell-gl.tar.gz ... Passed ==> Cleaning up... ==> Making package: hunspell-gl 2:18.07-1 (Mon 26 Aug 2019 01:33:17 AM CEST) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Missing dependencies: -> scons -> python2-pyicu ==> ERROR: Could not resolve all dependencies. Error making: hunspell-gl ```

[I] ➜ yay python2-pyicu
No packages match search

Could you please check it?