Package Details: hqplayer4 4.12.0-1

Git Clone URL: https://aur.archlinux.org/hqplayer4.git (read-only, click to copy)
Package Base: hqplayer4
Description: The high-end upsampling multichannel software HD-audio player
Upstream URL: http://www.signalyst.com/consumer.html
Keywords: audio resampler
Licenses: custom
Submitter: blackhole
Maintainer: blackhole
Last Packager: blackhole
Votes: 3
Popularity: 0.019075
First Submitted: 2019-04-27 08:06
Last Updated: 2021-06-06 14:34

Latest Comments

FarStar commented on 2021-03-11 16:55

Thank you. I'll look into it.

blackhole commented on 2021-03-11 06:09

External control applications: HQPDcontrol Android / iOS Roon muso Alchemy Desktop (see signalyst site)

FarStar commented on 2021-03-11 04:30

Hello blackhole,

I didn't know that other clients could be used with HQPlayer. Could you recommend some, please?

Thanks in advance.

blackhole commented on 2021-03-05 14:16

I have released version 4.10.2 based on the focal package.

The client will not work because it has been compiled with a QT version older than the one in Archlinux, but really almost no-one is using it but other more complete clients.

blackhole commented on 2021-02-26 13:59

Version 4.10.2 is out but...

Archlinux versions are based on Signalyst Fedora package.

The situation:

1) HQPlayer Desktop 4.10.2 crashes after few seconds.

2) There is not yet a version 4.22.2 for HQPlayer embedded in Fedora

I would wait some days.

I could tell you how to install manually a package using the Ubuntu focal package but...

1) HQPlayer Desktop will work fine, but not the client (it has been compiled with a QT version older than the one in Archlinux)

2) HQPlayer embedded from focal will install a lot of libraries for AMD GPU acceleration (total size > 2,5 GB!)

FloatyMcBoatface commented on 2020-12-03 08:04

It appears I am on qt 5.15.2-1, perhaps I am too far ahead being on the testing branch of Manjaro KDE.

FloatyMcBoatface commented on 2020-12-03 06:27

Oh ok, so its not something I messed up someplace in my system. Thanks for the quick reply. I'll decide where to go from here.

blackhole commented on 2020-12-03 06:13

Launching client there this error:

qrc:/files/qml/SplashScreen.qml: File was compiled ahead of time with an

incompatible version of Qt and the original file cannot be found. Please recompile

QQmlApplicationEngine failed to load component

qrc:/files/qml/MainScreen.qml: File was compiled ahead of time with an

incompatible version of Qt and the original file cannot be found. Please

recompile


Naturally I cannot recompile a closed source application.

The answer from developer is "Focal has Qt 5.12.8 at the moment. It should work fine there, since that's where it was built on. 4.7.2 was still built on Bionic."

You can downgrade to previous version modifying the PKGBUILD or wait for next Qt

release. All original deb packages can be found here:

https://www.signalyst.eu/bins/hqplayer/?

..or I could downgrade the PKGBUILD here

FloatyMcBoatface commented on 2020-12-03 05:56

AS of the last update I am no longer able to open the Client on my desktop. I am running Manjaro with KDE 5.20.4 It worked previously. Any ideas what may be going on at my end?