Package Details: hopper 4.7.3-1

Git Clone URL: https://aur.archlinux.org/hopper.git (read-only, click to copy)
Package Base: hopper
Description: Reverse engineering tool that lets you disassemble, decompile and debug your applications
Upstream URL: https://www.hopperapp.com/
Keywords: decompiler disassembler
Licenses: Commercial
Conflicts: hopperv4
Provides: hopperv4
Submitter: osospeed
Maintainer: jonathon
Last Packager: jonathon
Votes: 27
Popularity: 0.102230
First Submitted: 2016-06-30 20:41
Last Updated: 2021-03-31 19:20

Latest Comments

1 2 Next › Last »

bokic commented on 2021-01-23 22:20

Seems like we dont need temporary fixup anymore. Should be removed.

# Temporary hacky fix for upstream packaging issue
cd "$pkgdir"/opt/hopper-v4/lib
ln -s /usr/lib/libformw.so.6    libform.so.6
ln -s /usr/lib/libncursesw.so.6 libncurses.so.6
ln -s /usr/lib/libtinfo.so.6    libtinfo.so.6

flacs commented on 2020-01-17 01:23

Currently python2 is a hard dependency; without it Hopper will fail to load. I already contacted the developer and they said they plan to migrate to Python 3 (no time frame mentioned).

jonathon commented on 2020-01-16 23:51

namcap he say:

hopper E: Dependency python2 detected and not included (libraries ['usr/lib/libpython2.7.so.1.0'] needed in files ['opt/hopper-v4/lib/libHopperCore.so'])

So, the question is whether python2 really is needed?

DuBistKomisch commented on 2020-01-16 02:25

any chance this can use python3 now that 2 is EOL, or make python an optional dependency? not sure what it's actually used for

m3thodic commented on 2017-12-17 07:13

@jonathon As Slackware being my first distro back in '96 and Arch since '04, I agree with installing into /opt.

jonathon commented on 2017-10-04 18:38

@Martchus Nice idea, but I'm not putting potentially conflicting libraries into /usr/lib/. ;)

See also:
http://refspecs.linuxfoundation.org/FHS_3.0/fhs/ch03s13.html

"hopper" is most definitely an "add-on" application as it's not part of the standard distro and isn't compiled against system libraries, so it seems to me that /opt is the most appropriate place for it.

Martchus commented on 2017-10-04 18:25

Here is a version which uses as much system provided libraries as possible and doesn't put stuff under /opt: https://github.com/Martchus/PKGBUILDs/blob/master/hopper/default/PKGBUILD

jonathon commented on 2017-09-02 11:33

Upstream download link for 4.2.15 Arch package was returning 403, that's now fixed. pkgbump incoming.

auscompgeek commented on 2017-08-12 03:18

The builtin help expects /usr/share/doc/hopperv4/English.lproj/script.html to exist.

jonathon commented on 2017-04-12 09:21

Updated and merge requested.