Package Details: hipsparse 3.9.0-1

Git Clone URL: https://aur.archlinux.org/hipsparse.git (read-only, click to copy)
Package Base: hipsparse
Description: rocSPARSE marshalling library.
Upstream URL: https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#hipsparse
Licenses: MIT
Submitter: naetherm
Maintainer: naetherm (farnoy, rsa, acxz)
Last Packager: acxz
Votes: 0
Popularity: 0.000000
First Submitted: 2020-02-01 13:54
Last Updated: 2020-11-29 16:24

Pinned Comments

naetherm commented on 2020-06-05 05:28

Development is on Github: https://github.com/rocm-arch/rocm-arch Please open issues and PRs there instead of commenting.

Latest Comments

naetherm commented on 2020-06-05 05:28

Development is on Github: https://github.com/rocm-arch/rocm-arch Please open issues and PRs there instead of commenting.

dstego commented on 2020-05-30 20:52

The PKGBUILD for this is a bit of a mess.

First there is a "hip>=$pkgver" that needs to be removed otherwise a missing dependency error will occur.

Next make install needs to be make DESTDIR="$pkgdir" install otherwise it will try to move the files to a folder without proper write permissions.

Finally it tries to run cp -r "$srcdir/build/opt" "$pkgdir/" but that folder doesn't exist, so just delete that line.

Even after all that there is an issue that arises because it will complain that it can't find Findhip.cmake because the file is called FindHIP.cmake. To fix that you need to find the rocsparse directory and edit rocsparse-config.cmake to replace find_dependency(hip) with find_dependency(HIP).

Maverick commented on 2020-05-07 00:10

makepkg crashes for me with "==> Missing dependencies: -> hip>=3.3.0" even though hip-hcc 3.3.0-5 is already installed and should be providing it. Any idea what's going on?