Package Details: hip 2.5.0-1

Git Clone URL: https://aur.archlinux.org/hip.git (read-only)
Package Base: hip
Description: Heterogeneous Interface for Portability ROCm
Upstream URL: https://github.com/ROCm-Developer-Tools/HIP
Submitter: cdkitching
Maintainer: farnoy
Last Packager: farnoy
Votes: 3
Popularity: 0.281805
First Submitted: 2017-10-14 23:44
Last Updated: 2019-06-25 10:43

Pinned Comments

farnoy commented on 2019-07-14 19:38

Ok, so 2.6.0 added a dependency for comgr, which comes from ROCm-CompileSupport repo. That in turn requires their own custom build of LLVM, LLD and clang, which I'm not inclined to set up. The hcc repo that builds this stuff at least uses git modules and a shared cmake build, this I would have to set up manually.

If anyone wants to contribute this update, that would be great, otherwise I'm probably not going to invest time in it, since HIP doesn't even work for me on the simplest examples they give.

Latest Comments

rigred commented on 2019-08-20 09:31

Going to see about fixing this up with the new custom compilers they added.

farnoy commented on 2019-07-14 19:38

Ok, so 2.6.0 added a dependency for comgr, which comes from ROCm-CompileSupport repo. That in turn requires their own custom build of LLVM, LLD and clang, which I'm not inclined to set up. The hcc repo that builds this stuff at least uses git modules and a shared cmake build, this I would have to set up manually.

If anyone wants to contribute this update, that would be great, otherwise I'm probably not going to invest time in it, since HIP doesn't even work for me on the simplest examples they give.

aviallon commented on 2019-07-14 15:37

@farnoy

Version 2.6.0 is already realeased ! What a fast pace !

farnoy commented on 2019-06-25 10:42

@aviallon Thanks, this fixes one source of references to $srcdir, I still don't know how to fix the shared & static libraries with these references though :(

aviallon commented on 2019-06-17 20:58

@farnoy I found a workaround for the refs to $srcdir. It actually caused me a build failure for rocfft, so I really had to fix it. I added sed -i "s+$pkgdir/opt+/opt+g" "$pkgdir/opt/rocm/hip/lib/cmake/hip/hip-targets-release.cmake" before rm -r in package()

Also, version 2.5.0 seems to be released.

uhrm commented on 2019-01-20 19:14

This package built fine without the 'rocminfo' package. Is this dependency really needed?

(I'm asking since I have troubles building rocminfo.)

farnoy commented on 2018-12-21 23:08

@dmidge If you're still interested, it should be fine now. Be careful building the dependency hcc, it takes a lot of time and a lot of space too, so don't do it on a tmpfs partition.

dmidge commented on 2018-05-18 22:37

Hi, I have a problem to install hip. It says:

Don't know where to find HCC. Please specify abolute path using -DHCC_HOME

It seems that a dependency is missing on HCC. But then, I need closed source software then?