Package Details: heroku-toolbelt 3.43.9-1

Git Clone URL: https://aur.archlinux.org/heroku-toolbelt.git (read-only)
Package Base: heroku-toolbelt
Description: Everything you need to get started using Heroku
Upstream URL: https://toolbelt.heroku.com
Licenses: MIT
Conflicts: heroku-client-standalone, heroku-toolbelt, ruby-heroku
Provides: heroku-client-standalone, heroku-toolbelt, ruby-heroku
Submitter: WhyNotHugo
Maintainer: WhyNotHugo
Last Packager: WhyNotHugo
Votes: 165
Popularity: 0.000154
First Submitted: 2016-02-03 15:44
Last Updated: 2016-08-30 21:18

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

transience commented on 2014-06-04 09:25

ruby is a dependency.

brisbin33 commented on 2014-05-17 13:55

For anyone who cares, I made a PKGBUILD that installs the (recommended) standalone version:

https://aur.archlinux.org/packages/heroku-client-standalone

brisbin33 commented on 2014-05-17 12:49

Has been failing to build for me for a while.

==> Starting package()...
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will break this
application for all non-root users on this machine.
Fetching gem metadata from http://rubygems.org/.........
Fetching additional metadata from http://rubygems.org/..
Installing dotenv 0.7.0
Installing addressable 2.3.6
Installing excon 0.32.1
Installing thor 0.18.1
Installing netrc 0.7.7
Installing multi_json 1.9.2
Installing rubyzip 1.1.2
Using bundler 1.6.2
Installing mime-types 2.2
Installing launchy 2.4.2
Installing foreman 0.63.0
Installing heroku-api 0.3.18
Installing rest-client 1.6.7
Installing heroku 3.6.0
Unfortunately, a fatal error has occurred. Please see the Bundler troubleshooting documentation at
http://bit.ly/bundler-issues. Thanks!
/usr/lib/ruby/2.1.0/rubygems/basic_specification.rb:200:in `require_paths': undefined method `empty?' for nil:NilClass (NoMethodError)
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/endpoint_specification.rb:28:in `require_paths'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/installer.rb:238:in `block in generate_standalone'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/installer.rb:236:in `generate_standalone'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/installer.rb:95:in `run'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/installer.rb:15:in `install'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/cli/install.rb:78:in `run'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/cli.rb:146:in `install'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/vendor/thor/command.rb:27:in `run'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/vendor/thor/invocation.rb:121:in `invoke_command'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/vendor/thor.rb:363:in `dispatch'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/vendor/thor/base.rb:440:in `start'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/cli.rb:9:in `start'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/bin/bundle:20:in `block in <top (required)>'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/lib/bundler/friendly_errors.rb:5:in `with_friendly_errors'
from /usr/lib/ruby/gems/2.1.0/gems/bundler-1.6.2/bin/bundle:20:in `<top (required)>'
from /usr/bin/bundle:23:in `load'
from /usr/bin/bundle:23:in `<main>'
==> ERROR: A failure occurred in package().
Aborting...

I am building with chruby-exec system. I believe this is a different, new issue.

wgardiner commented on 2014-05-15 14:49

@wengole I had a problem, and was using a ruby version manager (RVM), and solved it by running `rvm system`( as mentioned in the comments of the ruby-bundler aur page here https://aur.archlinux.org/packages/ruby-bundler/ ), installing ruby-bundler, then installing heroku-toolbelt

if this doesn't work for you, you could try `chruby system` (also mentioned in the comments of the ruby-bundler aur page)

wengole commented on 2014-03-25 07:43

Unable to install.

Post-install message from heroku:
! The `heroku` gem has been deprecated and replaced with the Heroku Toolbelt.
! Download and install from: https://toolbelt.heroku.com
! For API access, see: https://github.com/heroku/heroku.rb
find: `/usr/lib/ruby/vendor_ruby/heroku-toolbelt/vendor/bundle/ruby': No such file or directory
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build .

discord commented on 2014-03-24 18:04

==> Installing missing dependencies...
error: target not found: ruby-bundler

SimFox3 commented on 2014-03-24 01:10

There is v3.6.0 out

fmauNeko commented on 2013-11-12 02:22

There's a version 3.01 of this, to be up-to-date, switch to ruby-heroku package.

oneeyed commented on 2013-08-24 08:34

There is a warning while installing heroku-toolbelt:

==> WARNING: Package contains reference to $pkgdir

ymek commented on 2013-08-17 09:12

I updated the PKGBUILD to use the latest heroku-provided package.
https://github.com/ymek/aur-heroku-toolbelt/blob/master/PKGBUILD