Package Details: heroku-toolbelt 3.43.9-1

Git Clone URL: https://aur.archlinux.org/heroku-toolbelt.git (read-only)
Package Base: heroku-toolbelt
Description: Everything you need to get started using Heroku
Upstream URL: https://toolbelt.heroku.com
Licenses: MIT
Conflicts: heroku-client-standalone, heroku-toolbelt, ruby-heroku
Provides: heroku-client-standalone, heroku-toolbelt, ruby-heroku
Submitter: WhyNotHugo
Maintainer: WhyNotHugo
Last Packager: WhyNotHugo
Votes: 165
Popularity: 0.000154
First Submitted: 2016-02-03 15:44
Last Updated: 2016-08-30 21:18

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

brisbin33 commented on 2016-02-03 16:25

@hobarrera

Got your merge request, sounds great! What do I do?

WhyNotHugo commented on 2016-01-21 17:37

I've adopted this package, rewritten it, and update it. Let me know if you have any issues.

The `heroku` command is now present in the default path.

WhyNotHugo commented on 2016-01-21 17:37

I've adopted heroku-toolbelt, and updated it using something extremely similar to what this package currently is.

How would you feel about merging the both of them?

jakhead commented on 2016-01-20 23:11

Edit Gemfile.lock to include json in GEM and DEPENDENCIES section like so:

GEM
remote: http://rubygems.org/
...
json (1.8.3)

PLATFORMS
ruby

DEPENDENCIES
foreman (= 0.78.0)
heroku (= 3.42.15)
json (= 1.8.3)

BUNDLED WITH
1.10.6



Add json to Gemfile like so:

source "http://rubygems.org"
gem "heroku", "3.42.15"
gem "foreman", "0.78.0"
gem "json", "1.8.3"


Update sha256sums and all set.

jakhead commented on 2016-01-20 22:48

Same for me:

Your Gemfile.lock is corrupt. The following gem is missing from the DEPENDENCIES section: 'json'
==> ERROR: A failure occurred in package().
Aborting...

WhyNotHugo commented on 2016-01-11 15:52

Your Gemfile.lock is corrupt. The following gem is missing from the DEPENDENCIES section: 'json'
==> ERROR: A failure occurred in package().
Aborting...

ingmferrer commented on 2016-01-04 16:57

$ heroku
/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- heroku-api (LoadError)
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/vendor_ruby/heroku-toolbelt/vendor/bundle/ruby/2.2.0/gems/heroku-3.42.15/lib/heroku/command.rb:6:in `<top (required)>'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/vendor_ruby/heroku-toolbelt/vendor/bundle/ruby/2.2.0/gems/heroku-3.42.15/lib/heroku/cli.rb:25:in `start'
from /usr/lib/ruby/vendor_ruby/heroku-toolbelt/vendor/bundle/ruby/2.2.0/gems/heroku-3.42.15/bin/heroku:17:in `<top (required)>'
from /usr/bin/heroku:12:in `load'
from /usr/bin/heroku:12:in `<main>'

grimsock commented on 2015-10-15 23:07

@neverfox Still getting that issue?

sindrenm commented on 2015-09-20 01:12

As you mention, it's pretty much self-updating now, which is also how I noticed that 3.41.5 is available. So flagging this is pretty much just a heads up in case you feel like upgrading it. :-)

neverfox commented on 2015-01-22 01:33

/usr/lib/ruby/2.2.0/rubygems/dependency.rb:315:in `to_specs': Could not find 'bundler' (>= 0) among 10 total gem(s) (Gem::LoadError)
Checked in 'GEM_PATH=/home/roman/.gem/ruby/2.2.0:/usr/lib/ruby/gems/2.2.0', execute `gem env` for more information
from /usr/lib/ruby/2.2.0/rubygems/dependency.rb:324:in `to_spec'
from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_gem.rb:64:in `gem'
from /usr/bin/bundle:22:in `<main>'
==> ERROR: A failure occurred in package().
Aborting...