Package Details: heidisql 10.2.0.5599-2

Git Clone URL: https://aur.archlinux.org/heidisql.git (read-only)
Package Base: heidisql
Description: A lightweight GUI for managing MySQL, PostgreSQL, and Microsoft SQL databases. This package uses the latest nightly build (64bit) on top of the portable version, and uses Wine.
Upstream URL: http://www.heidisql.com/
Licenses: GPL
Submitter: liviucmg
Maintainer: liviucmg
Last Packager: liviucmg
Votes: 44
Popularity: 1.01
First Submitted: 2012-12-12 12:03
Last Updated: 2019-07-10 16:42

Latest Comments

1 2 3 4 Next › Last »

dcelasun commented on 2019-10-31 09:37

@liviucmg: Since there are multiple problems [1][2] with recent versions of Wine, would you consider bundling a known-working version of Wine?

[1] https://github.com/HeidiSQL/HeidiSQL/issues/723

[2] https://github.com/HeidiSQL/HeidiSQL/issues/630

javum commented on 2019-10-31 04:05

Crashes on latest Wine 4.18

Copying to ~/.heidisql doesn't help

hrvoj3e commented on 2019-06-18 10:03

@liviucmg You should add MariaDB DLL also - MariaDB stoped working in this release. For a quick fix edit /usr/bin/heidisql and add line
ln -s "$progRealPath/libmariadb.dll" "$progHome/libmariadb.dll" >/dev/null 2>&1. Then run it once bash /usr/bin/heidisql.

liviucmg commented on 2019-06-15 07:47

Upgraded to 10.2.0.5599, and from 32 to 64bit. Note that author recommends Wine 4.10. I tried it and seems to work properly with symlinks.

dcelasun commented on 2019-05-14 16:31

Can confirm, I fixed it by removing the symlinks and copying everything into ~/.heidisql.

cosarara97 commented on 2019-05-14 16:29

Looks like symlink support broke with the latest wine-staging (4.8):

wine: cannot find '/home/jaume/.heidisql/heidisql.exe'

Installing normal wine fixes it.

mlamm commented on 2019-05-13 08:58

Confirmed working again with wine-4.8-1

hrvoj3e commented on 2019-04-30 13:56

https://github.com/HeidiSQL/HeidiSQL/issues/630 https://forum.winehq.org/viewtopic.php?f=8&t=32337 If someone has the know-how to debug wine.

dcelasun commented on 2019-04-30 08:19

Perhaps it's better to include a bundled copy of wine with this package?

mlamm commented on 2019-04-30 08:18

Same with wine-4.7-1