Package Details: hamsket-git r1133.433cadb-1

Git Clone URL: https://aur.archlinux.org/hamsket-git.git (read-only, click to copy)
Package Base: hamsket-git
Description: Free and Open Source messaging and emailing app that combines common web applications into one.
Upstream URL: https://github.com/TheGoddessInari/hamsket
Licenses: GPL3
Conflicts: hamsket, hamsket-bin, rambox, rambox-bin, rambox-os, rambox-os-git, ramboxpro-bin
Provides: hamsket
Replaces: rambox-os-git
Submitter: bserckx
Maintainer: theSander
Last Packager: bserckx
Votes: 4
Popularity: 0.008786
First Submitted: 2019-08-02 10:24
Last Updated: 2019-11-04 16:23

Pinned Comments

bserckx commented on 2019-08-06 09:50

Hamsket is the new name for Rambox-OS. Please use this package instead of rambox-os-git.

bserckx commented on 2019-08-06 09:49

As rjt said, Rambox-OS is renamed to Hamsket. I made a new package for the git version, located at hamsket-git (https://aur.archlinux.org/packages/hamsket-git/). Please switch to the new package.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

bserckx commented on 2019-01-24 22:19

@bjo I think it's the same error as below, namely Sencha CMD does only work correctly with Java 8 or earlier. If you have Java 8 as default runtime it should build. I don't know what would be the appropriate way to fix this, help is sure welcome.

bjo commented on 2019-01-24 17:06

Building fails here:

9 verbose lifecycle @~compile: CWD: /home/build/rambox-os-git/src/rambox-os
10 silly lifecycle @~compile: Args: [ '-c',
10 silly lifecycle   'sencha app build && cpy app/package.json app/package-lock.json build/production/Rambox/ && npm run buildversion' ]
11 silly lifecycle @~compile: Returned: code: 65  signal: null
12 info lifecycle @~compile: Failed to exec compile script
13 verbose stack Error: @ compile: `sencha app build && cpy app/package.json app/package-lock.json build/production/Rambox/ && npm run buildversion`
13 verbose stack Exit status 65
13 verbose stack     at EventEmitter.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:301:16)
13 verbose stack     at EventEmitter.emit (events.js:188:13)
13 verbose stack     at ChildProcess.<anonymous> (/usr/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack     at ChildProcess.emit (events.js:188:13)
13 verbose stack     at maybeClose (internal/child_process.js:978:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:265:5)
14 verbose pkgid @
15 verbose cwd /home/build/rambox-os-git/src/rambox-os
16 verbose Linux 4.20.3-arch1-1-ARCH
17 verbose argv "/usr/bin/node" "/usr/bin/npm" "run" "compile"
18 verbose node v11.7.0
19 verbose npm  v6.7.0
20 error code ELIFECYCLE
21 error errno 65
22 error @ compile: `sencha app build && cpy app/package.json app/package-lock.json build/production/Rambox/ && npm run buildversion`
22 error Exit status 65
23 error Failed at the @ compile script.

bjo commented on 2018-12-13 22:50

I've created an AUR package for the binary builds: https://aur.archlinux.org/packages/rambox-os-bin/

bjo commented on 2018-12-13 13:53

Thanks for the hint!

bserckx commented on 2018-12-13 12:55

@bjo There is quite some controverse about the original rambox, leading to creation of a truly FOSS fork. See https://github.com/ramboxapp/community-edition/issues/1811 and https://github.com/ramboxapp/community-edition/issues/1810

bjo commented on 2018-12-05 18:45

Why do you use the fork instead of the usual repo?

bserckx commented on 2018-11-18 11:02

@bbaserdem : see previous comment

bserckx commented on 2018-11-10 17:09

I have found what is wrong: Sencha CMD 6 does not work with Java 9 or newer, it needs Java 8 or earlier. This should be specified in Sencha CMD's dependencies (which isn't). Building rambox-os in a clean chroot with the Sencha package, automatically grabs a (newer) JRE and sets it as default, so specifying it in rambox-os's makedepends does not work. (Well, I guess this is the reason it does not work) You need to modify Sencha CMD's PKGBUILD, and include that package in your chroot build.

I'll message sencha-cmd's maintainer to fix the PKGBUILD.

bserckx commented on 2018-11-10 12:00

I didn't have an error indeed. I am also not very familiar with NodeJS or Electron myself, but I'll have a look

bbaserdem commented on 2018-11-08 19:09

Trying to build this in clean chroot fails, I'm getting build error with log here; https://pastebin.com/MSV23j7p

I don't know much about nodejs, or electron. Any idea how I can fix this? (I assume people have built this package 2 days before successfully judging from the comments)