Package Details: hamsket-git r1133.433cadb-1

Git Clone URL: https://aur.archlinux.org/hamsket-git.git (read-only, click to copy)
Package Base: hamsket-git
Description: Free and Open Source messaging and emailing app that combines common web applications into one.
Upstream URL: https://github.com/TheGoddessInari/hamsket
Licenses: GPL3
Conflicts: hamsket, hamsket-bin, rambox, rambox-bin, rambox-os, rambox-os-git, ramboxpro-bin
Provides: hamsket
Replaces: rambox-os-git
Submitter: bserckx
Maintainer: theSander
Last Packager: bserckx
Votes: 4
Popularity: 0.004318
First Submitted: 2019-08-02 10:24
Last Updated: 2019-11-04 16:23

Pinned Comments

bserckx commented on 2019-08-06 09:50

Hamsket is the new name for Rambox-OS. Please use this package instead of rambox-os-git.

bserckx commented on 2019-08-06 09:49

As rjt said, Rambox-OS is renamed to Hamsket. I made a new package for the git version, located at hamsket-git (https://aur.archlinux.org/packages/hamsket-git/). Please switch to the new package.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

bserckx commented on 2019-05-17 18:10

Hi bertieb, could this be related to your nvm setup? I am still able to compile in a clean chroot.

bertieb commented on 2019-05-17 17:31

On install today I am getting a bunch of syntax-related errors, eg:

/tmp/trizen-bertieb/rambox-os-git/src/rambox-os/node_modules/electron-builder/node_modules/yargs/yargs.js:14 const { globalMiddlewareFactory } = require('./lib/middleware')

/tmp/trizen-bertieb/rambox-os-git/src/rambox-os/node_modules/electron-builder/node_modules/yargs/lib/command.js:5 const { applyMiddleware, commandMiddlewareFactory } = require('./middleware')

/tmp/trizen-bertieb/rambox-os-git/src/rambox-os/node_modules/electron-builder/node_modules/yargs/lib/middleware.js:13 return function (callback, applyBeforeValidation = false) {

which causes an error in:

npm ERR! Linux 5.0.13-arch1-1-ARCH
npm ERR! argv "/home/bertieb/.nvm/versions/node/v4.0.0/bin/node" "/home/robert/.nvm/versions/node/v4.0.0/bin/npm" "run" "compile" > npm ERR! node v4.0.0
npm ERR! npm v2.14.2
npm ERR! code ELIFECYCLE
npm ERR! @ compile: sencha app build && shx cp app/package.json app/package-lock.json build/production/Rambox/ && npm run buildversion && electron-builder install-app-deps npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the @ compile script 'sencha app build && shx cp app/package.json app/package-lock.json build/production/Rambox/ && npm run buildversion && electron-builder install-app-deps'.`

I can't tell if this is an issue upstream or here, can't find the files referred to in the upstream GH repo.

(apologies for the formatting)

bserckx commented on 2019-05-08 11:11

Should work now

bjo commented on 2019-05-07 11:03

Yes, chmod 4755 on /usr/lib/rambox-os/chrome-sandbox fixes it.

HanFox commented on 2019-05-07 07:52

Since the latest build the program fails to launch with:

[21877:0507/084731.629355:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /usr/lib/rambox-os/chrome-sandbox is owned by root and has mode 4755.

HanFox commented on 2019-02-20 04:45

Ah, well sencha-cmd has an update, so maybe the out-of-date flag will grab the maintainers attention.

bserckx commented on 2019-02-19 13:29

That does not work for clean builds, as sencha-cmd-6 first installs another java runtime, to which archlinux-java defaults after that.

sencha-cmd-6 should change its java-runtime dependency to java-runtime<=8, but the maintainer does not respond, so this is for now the best fix I can give afaik.

HanFox commented on 2019-02-19 13:09

Instead of specifying jre8-openjdk you could specify java-runtime=8 as a build dependency.

That should then avoid prompting to install jre8-openjdk if jdk8 or jre8 is already installed, but will still fetch openjdk if no Java is installed.

bserckx commented on 2019-01-25 11:44

I've added jre8-openjdk as a build dep, and fixed the build script so now it builds in a clean chroot without further intervention.

bserckx commented on 2019-01-24 23:16

Okay, I think I'm out. Sencha CMD require Java 8 or less. However, when installing in a clean chroot, it installs the java-runtime packages, which defaults to jre-openjdk, which is Java 11. So adding Java 8 or less to rambox-os' make-depends does not help, since the default java-runtime is still 11.

The workaround that I see, is to manually install a Java <=8 runtime like jre8-openjdk in the chroot before installing the package, using something like arch-nspawn $CHROOT/root pacman -Syu jre8-openjdk.

Upstream is planning to abandon ExtJS (and I guess Sencha CMD too).