Package Details: gzdoom 4.1.3-1

Git Clone URL: https://aur.archlinux.org/gzdoom.git (read-only)
Package Base: gzdoom
Description: Advanced Doom source port with OpenGL support
Upstream URL: http://www.zdoom.org/
Licenses: GPL3, BSD, LGPL3, custom:dumb
Replaces: gzdoom1
Submitter: None
Maintainer: grubber
Last Packager: grubber
Votes: 111
Popularity: 2.110256
First Submitted: 2009-02-22 22:28
Last Updated: 2019-06-10 10:15

Dependencies (33)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

Fincer commented on 2015-02-04 00:05

At the moment PKGBUILD messes with GZDoom version numbering, resulting to a <unknown version>. Instead of using tar.gz package (which is presented in the current PKGBUILD file), the package must be built with git method. I corrected the PKGBUILD file for those who want the correct GZDoom version number shown when launching the program.

See fixed PKGBUILD file for GZDoom 2.0.04 + all versions 1.8.5 and above here:

http://forum.drdteam.org/viewtopic.php?f=22&t=6524&p=56382#p56382

Fincer commented on 2015-02-03 23:54

At the moment PKGBUILD messes with GZDoom version numbering, resulting to a <unknown version>. Instead of using tar.gz package (which is presented in the current PKGBUILD file), the package must be built with git method. I corrected the PKGBUILD file for those who want the correct GZDoom version number shown when launching the program.

Also, the current PKGBUILD script lacks of FMOD Library compilation which should be included. I added compilation of the FMOD library to the PKGBUILD.

See fixed PKGBUILD file for GZDoom 2.0.04 + all versions 1.8.5 and above here:

http://forum.drdteam.org/viewtopic.php?f=22&t=6524&p=56382#p56382

Fincer commented on 2015-02-02 21:17

At the moment PKGBUILD messes with GZDoom version numbering, resulting to a <unknown version>. Instead of using tar.gz package (which is presented in the current PKGBUILD file), the package must be built with git method. I corrected the PKGBUILD file for those who want the correct GZDoom version number shown when launching the program. See fixed PKGBUILD file for GZDoom 2.0.04 here:

http://forum.drdteam.org/viewtopic.php?f=22&t=6524&p=56382#p56382

grubber commented on 2014-09-24 21:11

Updated to 2.0.03. See also <https://aur.archlinux.org/packages/gzdoom1/> for 1.8.7.

zanny: You can report bugs at <http://forum.drdteam.org/viewforum.php?f=24>.

zanny commented on 2014-09-22 01:14

So yeah, a lot of breakage in gz 2.0 with the Mesa drivers:

By default, it is using a compatibility profile and does not recognize core profiles supporting 3.3, so it just says "get GL 3.3".

If you override the Mesa version string with 3.3, it tries to use GLSL 4.0 shaders.

If you use the arg -gl3 to force 3.3, it fails to compile some fragment shader.

And I can't even find the gzdoom bug tracker. It isn't off their github repo and my google-fu is failing me.

remussatala commented on 2014-09-21 18:44

http://forum.drdteam.org/viewtopic.php?f=23&t=6398&sid=7693a043a7d4b804ef99fe932a76c6e1
http://forum.drdteam.org/viewtopic.php?f=23&t=6397&sid=7693a043a7d4b804ef99fe932a76c6e1

remussatala commented on 2014-09-11 17:26

If you want the original midi windows you can use this soundfont:
https://docs.google.com/file/d/0BypDM7HzdnkjcW5mRllVRS12eWc/edit

remussatala commented on 2014-09-11 09:40

Now I use GZdoom 1.8.6. Is ok. I created only for myself gzdoom-aur and chose version 1.8.6.

chungy commented on 2014-09-11 02:13

Instead of cloning the git repository, I suggest instead using https://github.com/coelckers/gzdoom/archive/g${pkgver}.tar.gz in the source array, and doing "cd gzdoom-g${pkgver}" in the build() function. Should be much faster to download, and puts less strain on GitHub's servers.

remussatala commented on 2014-09-10 22:53

:)
Unsupported OpenGL version.
At least OpenGL 3.3 is required to run GZDoom.

*** Fatal Error ***
!!! Failed to exec debug process
Segmentation fault (core dumped)

I have OpenGL 3.1 :D Intel® HD Graphics 2000