Package Details: guitarix-git 0.39.0.r504.g84b744b0-1

Git Clone URL: https://aur.archlinux.org/guitarix-git.git (read-only, click to copy)
Package Base: guitarix-git
Description: virtual guitar amplifier for Jack/Linux
Upstream URL: https://guitarix.org
Keywords: amplifier emulation guitar lv2 pro-audio tube
Licenses: GPL3
Groups: lv2-plugins, ladspa-plugins, pro-audio
Conflicts: guitarix
Provides: guitarix, libgxw.so, libgxwmm.so
Replaces: guitarix2
Submitter: None
Maintainer: Gimmeapill
Last Packager: Gimmeapill
Votes: 11
Popularity: 0.000000
First Submitted: 2012-04-13 09:51
Last Updated: 2020-05-20 08:35

Pinned Comments

Gimmeapill commented on 2017-12-03 20:10

This package will automatically retrieve and build the latest development snapshot of Guitarix from git.

It does not need to be updated on every release, so please do not flag out of date unless the build itself breaks or in case of an actual packaging issue.

If you are looking for the latest official release instead, see https://www.archlinux.org/packages/community/x86_64/guitarix2/

Latest Comments

1 2 3 4 5 6 Next › Last »

Gimmeapill commented on 2020-01-30 14:05

@hisacro: The faust dependency is purely optional (see my previous comment) and has been there for at least 5-6 years.

If you get a build failure, then the issue is elsewhere - probably either in the pkgbuild or upstream given the work in progress to modernize the build scripts.

hisacro commented on 2020-01-30 07:51

hi, new 0.39 version seems to have "faust" as dependency.

Gimmeapill commented on 2020-01-26 14:33

I didn't manage so far to isolate the flag causing the build issue, so I re-based the pkgbuild on the official package. It builds fine now, but I'll probably tweak a bit more the deps.

@ronjouch: gtk-engines is not needed if your .gtkrc-2.0 is configured properly = points to an existing gtk2 theme. From the 2nd answer in the ticket I don't have the impression that it's going to be added to the dependency array.

Regarding faust: it is needed at build time only to convert the .dsp to C++ files. But that's entirely optional, since prebuilt C++ are also provided. I never had particularly good experiences with that build flag across faust version, so I'm excluding it with "--no-faust"

ronjouch commented on 2020-01-20 21:37

Hi Gimmeapill!

This package builds as of today, but it misses at least one (maybe 2) dependencies:

  1. gtk-engines is needed as dep, else the app appears with unreadable buttons (white-text-on-gray-background). This one was acknowledged by the maintainer of the official non-git Arch package at https://bugs.archlinux.org/task/65210 , and they say it will be fixed soon.

  2. Also, faust might be needed as makedep? I don't understand why it's not in the official package makedeps, though. Still, build fails without it. Up to you, not sure about that one.

Thanks for the packaging! :)

Gimmeapill commented on 2020-01-20 19:53

It's badly broken at the moment probably due to the latest wscript changes and the fixes for python 3.

I'll probably have to raise a bug report.

0.39 is anyway packaged, so this shouldn't be too much an issue:

https://www.archlinux.org/packages/community/x86_64/guitarix/

Gimmeapill commented on 2020-01-20 07:24

@milk: thx. That must be one of the recent changes as I build it last week without issue. I'll look at it asap.

milk commented on 2020-01-17 18:22

Getting this atm:

Cloning into bare repository '/home/pkguser/src/guitarix-git/guitarix'...
    guitarix ... Skipped
Cloning into 'guitarix'...
done.
Could not find the program ['faust']
(complete log in /home/pkguser/src/guitarix-git/src/guitarix/trunk/build/config.log)
==> ERROR: A failure occurred in build().

Gimmeapill commented on 2018-01-26 09:06

Builds flags have been updated following upstream changes (see wscript in the src dir.). Noticeable Changes:

  • Mod UI is not build anymore.

  • Package is now way smaller (from ~80MB to ~40MB), probably because of the above.

  • Legacy ladspa plugins are not built anymore (they are unmaintained and will be removed soon).

  • New ladspa plugins are still built, although they are probably going to be deprecated as well (please let upstream know if you use them).

  • Ttf-roboto is now an external dependency since there is an official package.

  • Compiler optimizations should stay the same

Gimmeapill commented on 2018-01-23 12:19

@SpotlightKid: Nah, you're right, I don't remember how it ended up here (possibly a copy paste from the namcap output). Thanks for letting me know ;-)

SpotlightKid commented on 2018-01-23 12:02

Shouldn't 'git' be in makedepends instead of depends? Or is it really needed at run-time?