Package Details: guitar-pro 11686-6

Git Clone URL: https://aur.archlinux.org/guitar-pro.git (read-only, click to copy)
Package Base: guitar-pro
Description: A popular tablature editor software for guitar, bass, and many other instruments.
Upstream URL: http://www.guitar-pro.com
Licenses: proprietary
Submitter: sergej
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 39
Popularity: 0.000537
First Submitted: 2010-04-11 20:21
Last Updated: 2020-01-06 19:47

Dependencies (24)

Required by (0)

Sources (3)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ansgoati commented on 2021-02-17 20:51

It's not possible to built the package 64 bit only ??

chrisjbillington commented on 2021-02-14 01:50

@xavierbaez I see this issue too. It's obviously a bug displaying text, and I think this package needs some work before it will work on Arch again.

The language isn't actually wrong, but the wrong glyphs are being displayed (I think the glyphs I see are Tamil). I see that if I copy and paste some of this strange-looking text to a different program, it is actually English. So I think the text rendering is borked, it's somehow picking glyphs from the Tamil part of Unicode instead of the correct glyphs.

xavierbaez commented on 2021-02-13 22:52

Hello How can I make the software run in English?

When it launches, it sounds looks like arabic, hebrew

chrisjbillington commented on 2020-03-15 19:39

Getting a segfault on launch, anyone else? Have done a clean install and my system is up to date so not a partial upgrade situation:

./GuitarPro: ./libcrypto.so.0.9.8: no version information available (required by ./GuitarPro)
Object::connect: No such signal PlaySettingsWidget::tuningChanged() in /var/jenkins/workspace/guitar-pro-6-std-linux/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133
Object::connect: No such signal BankListWidget::tuningChanged() in /var/jenkins/workspace/guitar-pro-6-std-linux/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133
Object::connect:  (sender name:   'SearchTreeWidget')
Object::connect: No such signal QWidget::tuningChanged() in /var/jenkins/workspace/guitar-pro-6-std-linux/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133
Object::connect:  (sender name:   'TrackMidiProperties')
Segmentation fault (core dumped)

Also, the GUI pops up for a second (and a dialog presumably saying 'There was a crash last time, do you want to recover files'), but the language or font is incorrect - a non-latin script is used (looks like maybe Tamil?) though I am en_AU.UTF-8.

br-lemes commented on 2020-01-03 14:20

I had to install lib32-libxslt. Shouldn't we add this as a dependency?

An7ar35 commented on 2019-10-31 19:37

The link ("https://guitar-pro.com/download.php?idfile=gp6_linux") in the PKGBUILD file for getting GP6 from Arobas Music's site doesn't seem to work any longer.

It needs to be changed to "https://downloads.guitar-pro.com/gp6/gp6-full-linux-r11686.deb" for it to work.

@robertfoster: Can you make the change? Thanks. Not quite sure how to submit a patch here.

On a side note: as GP6 is not supported now it might be an idea for anyone still using this to back up the .deb installation file locally in case Arobas decide to permanently remove it from their site in the future. Just in case...

GXGOW commented on 2018-04-22 12:29

gksu has been depracated and now removed from the repositories. Is it absolutely needed to build this package?

BrianAllred commented on 2018-02-01 21:24

Dropbox links are broken.

An7ar35 commented on 2017-12-20 02:59

@MaryJaneInChain Don't know if it will work for you but I have the same sort of problems when I authenticate GP6 for current user only. After that it crashes.

The way I remedied this was to register for all users (tick box on the registration popup that comes up after every linux kernel updates). It should then present you with a gksudo password prompt. After succesful authentication/registration it should work.

MaryJaneInChain commented on 2017-09-24 14:52

When I was opening or creating any .gpx file, it just caused a segfault and then crushed, I run dmesg and get this:

[ 8309.713877] GuitarPro[4671]: segfault at 8 ip 00000000f72ca816 sp 00000000ffcd9418 error 4 in libQtGui.so.4[f707f000+a70000]

Can someone help me?