Package Details: guiscrcpy 4.10.0-1

Git Clone URL: https://aur.archlinux.org/guiscrcpy.git (read-only, click to copy)
Package Base: guiscrcpy
Description: Open Source GUI based Android Screen Mirroring System
Upstream URL: https://guiscrcpy.github.io
Keywords: scrcpy
Licenses: GPL3
Submitter: yochananmarqos
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 13
Popularity: 0.095638
First Submitted: 2019-09-03 21:52
Last Updated: 2021-03-20 23:22

Dependencies (15)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

yochananmarqos commented on 2020-01-11 16:01

@srevinsaju: Create what tag? As you can see in the PKGBUILD, this pulls the 2.0 tag directly.

FYI, there's no such thing as "guiscrcpy-aur". This is the stable release package, guiscrcpy and guiscrcpy-git builds from the latest commit in the master branch.

srevinsaju commented on 2020-01-11 15:57

I guess guiscrcpy-aur has no tags in git. Try creating a tag in this repository, probably it would read that. One more thing, I have updated a security patch for guiscrcpy (3 commits). Thanks

yochananmarqos commented on 2020-01-11 15:55

@srevinsaju: It's working for guiscrcpy-git, it shows 2.0.post24 currently. Why can't it read the 2.0 tag? Patch what?

srevinsaju commented on 2020-01-11 07:29

@yochananmarqos, the gitpython extension is not working on guiscrcpy src. It gives v0.0.0 as the version. Consider overriding the version by a patch. gitpython is used to derive the version from the latest tag. Also, you can include AUR $pkgver-$pkgrel as the build number on the screen. Thanks

srevinsaju commented on 2019-09-23 04:02

guiscrcpy python packaging doesn't work see issue 11 on https://github.com/srevinsaju/guiscrcpy/issues/11. Moreover makefile does not exist on python3 due to the dynamic paths. I am looking forward for a better build system.

yochananmarqos commented on 2019-09-23 03:20

@srevinsaju: I've made a few changes. Please write a proper setup.py and / or Makefile that installs everything.

yochananmarqos commented on 2019-09-22 21:47

@srevinsaju: What's the right file, then?

Please do not flag packages out of date for requested changes. Only do that if the version is behind.

FYI, the Version in a desktop file is not the application version, it's the "Version of the Desktop Entry Specification that the desktop entry conforms with." See https://developer.gnome.org/desktop-entry-spec/

srevinsaju commented on 2019-09-22 19:39

guiscrcpy.sh and guiscrcpy.desktop points to the wrong file. Use native guiscrcpy-src-installer.sh and guiscrcpy.desktop from my github repo directly!

yochananmarqos commented on 2019-09-06 17:03

@Chrissss: adb is covered by scrcpy's dependency on android-tools.

Chrissss commented on 2019-09-06 16:49

Shouldn't be the android-tools a dependency, too? The package provides the adb binary, without it Guiscrcpy fails.

$ guiscrcpy
guiscrcpy v1.10.0-release
[...]
/bin/sh: 1: adb: not found
ADB: []
Traceback (most recent call last):
  File "__main__.py", line 1094, in start_act
IndexError: list index out of range
Abgebrochen (Speicherabzug geschrieben)