Package Details: guile-lib 0.2.6.1-2

Git Clone URL: https://aur.archlinux.org/guile-lib.git (read-only)
Package Base: guile-lib
Description: Repository of useful code written in Guile Scheme
Upstream URL: http://www.nongnu.org/guile-lib/
Licenses: GPL3, LGPL3
Submitter: tantalum
Maintainer: bidulock (holos, flatwhatson)
Last Packager: flatwhatson
Votes: 26
Popularity: 0.51
First Submitted: 2008-09-17 22:05
Last Updated: 2019-11-08 00:08

Latest Comments

flatwhatson commented on 2019-11-05 12:31

The following patch allows this to build properly for guile 2.2.

diff --git a/PKGBUILD b/PKGBUILD
index a1f409e..228ae2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ md5sums=('6457b08133e4baa54a438a11b18e9c30')

 build(){
   cd ${pkgname}-${pkgver}
-  ./configure --prefix=/usr
+  GUILE=/usr/bin/guile ./configure --prefix=/usr
   make
 }

early_adopter commented on 2019-05-11 12:31

Adding this clause to PKGBUILD allows it to compile

prepare() {
  cd ${pkgname}-${pkgver}
  sed -i 's/ 2.2/ /g' configure
}

exaos commented on 2019-03-28 15:05

failed to build due to the following error:

configure: error: found development files for Guile 2.2, but /usr/bin/guile2.0 has effective version 2.0

hubbi commented on 2018-11-20 12:16

fails to build. needs guile 2.2 it seems

beej commented on 2017-03-12 05:46

0.2.5 is now available upstream.

holos commented on 2016-11-17 23:42

yet another release http://www.nongnu.org/guile-lib/

holos commented on 2015-02-28 22:41

It would be nice if the info manual was included. http://ix.io/gDx http://ix.io/gDw

trebb commented on 2015-02-12 17:37

It doesn't install any more:
ERROR: Missing package() function in [...]/guile-lib/PKGBUILD

(Quick fix: s/build()/package()/ )