Package Details: guile-git 1:3.0.4.r38.g64c89458e-2

Git Clone URL: https://aur.archlinux.org/guile-git.git (read-only, click to copy)
Package Base: guile-git
Description: A portable, embeddable Scheme implementation (Git snapshot)
Upstream URL: http://www.gnu.org/software/guile/
Licenses: GPL
Conflicts: guile4emacs
Provides: guile
Submitter: pnorcks
Maintainer: None
Last Packager: haawda
Votes: 10
Popularity: 0.000000
First Submitted: 2010-01-12 19:52
Last Updated: 2020-12-11 23:13

Required by (98)

Sources (2)

Latest Comments

1 2 Next › Last »

haawda commented on 2020-12-10 16:46

Good catch, I have another idea how to fix this, but if that does not work, I will probably apply your solution.

hikmet1517 commented on 2020-12-10 04:32

info files are broken, filenames are changed but the references in guile-3.0.info point to guile.info-1, guile.info-2 etc. To prevent collision I renamed some parts of info files with sed.

after

do
  mv $i guile-${_majorver}${i#guile}
done

I put

sed -i "s/guile.info/guile-${_majorver}.info/g" guile-${_majorver}*
sed -i "s/guile.texi/guile-${_majorver}.texi/g" guile-${_majorver}*
sed -i "s/* Guile Reference: (guile)/* Guile-${_majorver} Reference: (guile-${_majorver})/g" guile-${_majorver}*
sed -i "s/The Guile reference manual./The Guile-${_majorver} reference manual./g" guile-${_majorver}*

I'm not sure that's the best way but i have both guile and guile-git installed, it looks like both info pages work now.

haawda commented on 2017-08-23 19:49

Added aarch64 to the architectures, no need for others to update.

phant0mas commented on 2017-08-23 13:28

This package works on aarch64 systems. You could add it on the supported systems.

haawda commented on 2016-12-16 20:27

New git version gives longer version numbers, no need to update.

haawda commented on 2016-09-22 20:07

For coincidence, the main developer of guile adviced me to do so, too.

ecraven commented on 2016-06-22 12:14

Could you remove CFLAGS=""?
The default CFLAGS (-O2 and so on) don't get set if you explicitly set it to "".

dlin commented on 2014-03-19 15:36

Why the depends are different than 'guile' package?

tantalum commented on 2013-06-08 12:37

updated to use pacman 4 git features

pnorcks commented on 2013-04-04 05:49

I am disowning this package, as well as 'guile-devel', due to lack of time.