Package Details: guayadeque-git 0.4.5.r2112.dfc4acb6-1

Git Clone URL: https://aur.archlinux.org/guayadeque-git.git (read-only)
Package Base: guayadeque-git
Description: Lightweight music player
Upstream URL: http://guayadeque.org/
Keywords: multimedia music player
Licenses: GPL3
Conflicts: guayadeque
Provides: guayadeque
Submitter: strubbl
Maintainer: strubbl
Last Packager: strubbl
Votes: 11
Popularity: 0.000010
First Submitted: 2016-05-15 18:56
Last Updated: 2019-04-14 12:06

Dependencies (14)

Required by (0)

Sources (1)

Latest Comments

1 2 3 Next › Last »

strubbl commented on 2019-06-09 16:34

@sleepywitti no, it is part of base-devel which is a requirement, which you should have already installed if you use aur packages. see https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

sleepywitti commented on 2019-06-09 14:03

I got the following error during compilation: -- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)

Installing pkgconf fixes the error. Maybe pkgconf should be added to makedepends.

michaelnix commented on 2019-04-18 16:48

Latest update rectified the problem.

michaelnix commented on 2019-04-11 15:00

Tried updating build this morning. Giving error 1 and error 2 with a bunch of undefined references.

https://pastebin.com/Ktf7LvFD

strubbl commented on 2017-10-23 13:12

with the most recent commit https://aur.archlinux.org/cgit/aur.git/commit/?h=guayadeque-git&id=8b068bedc288ea00dd39f1cbf10b4669712d1495 issues should be resolved. And I am using community/wxsqlite3 3.5.7-1 - not the one from the archive.

khaezaid commented on 2017-10-18 14:49

I installed wxsqlite3-3.4.1-2 from the Arch Linux Archive in combination with wxgtk2 and was able to get this package working that way.

strubbl commented on 2017-10-08 15:12

i guess not that soon: https://github.com/anonbeat/guayadeque/issues/54#issuecomment-334956109

seantum commented on 2017-10-08 09:39

When will the new, working version come out?

I get the following error message:

"(guayadeque:12767): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/Breakpoint ausgelöst (Speicherabzug geschrieben)"

I'm using the GIT Version.

strubbl commented on 2017-06-15 01:16

Currently there is a problem when launching guayadeque.

Workaround is to edit the PKGBUILD. is there a better way than to hardcode this path to wx-config-gtk3?

workaround:

$ git diff PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index a49b3db..646ea04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@

pkgname=guayadeque-git
_pkgname=guayadeque
-pkgver=0.4.5.r2050.9fec4f7b
+pkgver=0.4.5.r2063.35eaa957
pkgrel=1
pkgdesc='Lightweight music player'
arch=('i686' 'x86_64')
@@ -33,7 +33,8 @@ build() {
cmake . \
-DCMAKE_CXX_STANDARD='11' \
-DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr'
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3
make
}

Anonymous comment on 2017-01-08 17:02

It builds in a clean chroot and even with yaourt. Is your system up to date?

Seems the error is related to https://bugs.archlinux.org/task/49035
It's fixed in wxsqlite3 3.4.1-2