Package Details: gtk4 3.99.0-1

Git Clone URL: https://aur.archlinux.org/gtk4.git (read-only, click to copy)
Package Base: gtk4
Description: GObject-based multi-platform GUI toolkit
Upstream URL: https://www.gtk.org/
Keywords: gtk gtk4
Licenses: LGPL
Conflicts: gtk4-git, gtk4-print-backends, gtk4-update-icon-cache
Provides: gtk4, gtk4-print-backends, gtk4-update-icon-cache
Replaces: gtk4-print-backends, gtk4-update-icon-cache
Submitter: dariost
Maintainer: SilverRainZ
Last Packager: SilverRainZ
Votes: 12
Popularity: 1.20
First Submitted: 2017-04-09 10:42
Last Updated: 2020-08-09 14:15

Required by (1)

Sources (5)

Pinned Comments

SilverRainZ commented on 2020-08-09 14:17

GTK4 now updated to 3.99.0, plz checkout: https://gitlab.gnome.org/GNOME/gtk/blob/3.99.0/NEWS

NOTE that pango 1.45+ is required.

Latest Comments

1 2 Next › Last »

SilverRainZ commented on 2020-08-09 14:17

GTK4 now updated to 3.99.0, plz checkout: https://gitlab.gnome.org/GNOME/gtk/blob/3.99.0/NEWS

NOTE that pango 1.45+ is required.

SilverRainZ commented on 2020-06-26 03:59

We have to stay at 3.98.4 because 3.98.5 require pango 1.45.

SilverRainZ commented on 2020-05-22 15:23

@jhass should be fixed in 3.98.4.

jhass commented on 2020-05-14 16:14

It doesn't build for me:

../gdk/gdkvulkancontext.c: In function ‘gdk_vulkan_strerror’:
../gdk/gdkvulkancontext.c:212:10: error: ‘VK_RESULT_RANGE_SIZE’ undeclared (first use in this function)
  212 |     case VK_RESULT_RANGE_SIZE:

Am I missing something?

SilverRainZ commented on 2020-02-12 08:45

GTK4 now updated to 3.98.0, plz checkout: https://gitlab.gnome.org/GNOME/gtk/blob/3.98.0/NEWS

SilverRainZ commented on 2019-09-15 03:56

@pdxleif Thank you, I had unpinned the previous comment.

pdxleif commented on 2019-09-14 20:30

graphene in [extra] is currently 1.10.0-1, so it doesn't seem like graphene-git is a requirement any more.

SilverRainZ commented on 2019-05-15 10:12

GTK 3.96 requires graphene>1.9.1, use aur/graphene-git please.

SilverRainZ commented on 2018-06-28 06:34

@refi.64 Thank you, updated.

refi.64 commented on 2018-06-27 16:13

Patch with updates to build 3.94: http://termbin.com/gobbu

GTK+ 4 has dropped loadable input method modules, so gtk4-query-immodules no longer needs to be run. I also updated the Wayland and GLib dependency requirements.