Package Details: gtk4-git 3.94.0.r400.g0edec9bcae-1

Git Clone URL: https://aur.archlinux.org/gtk4-git.git (read-only)
Package Base: gtk4-git
Description: GObject-based multi-platform GUI toolkit (GIT Version)
Upstream URL: https://www.gtk.org/
Licenses: LGPL
Submitter: andrewSC
Maintainer: andrewSC
Last Packager: andrewSC
Votes: 15
Popularity: 0.000156
First Submitted: 2016-11-18 20:17
Last Updated: 2018-09-10 16:12

Required by (0)

Sources (6)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 Next › Last »

Anonymous comment on 2013-01-13 14:19

dengor, your bug was fixed in GTK+ 3.4.2. The reason is updating CUPS to 1.6 version. If you are using older version of GTK+, apply this patches manually: https://bugzilla.gnome.org/show_bug.cgi?id=670373

Det commented on 2013-01-07 21:46

Wanna update or disown?

Anonymous comment on 2012-10-04 07:53

In addition to the dependency mentioned by unknown:
- As the pango-unstable package is now out of date, the pango-git package is required instead.
- The atk package is too old, so this package requires atk-git instead.

unknown commented on 2012-08-29 14:16

Please add at-spi2-atk-git as a dependency.

Anonymous comment on 2012-08-04 15:53

gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: warning: left-hand operand of comma expression has no effect [-Wunused-value]
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: warning: value computed is not used [-Wunused-value]
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: warning: left-hand operand of comma expression has no effect [-Wunused-value]
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1838:12: error: dereferencing pointer to incomplete type
gtkprintbackendcups.c:1840:37: error: dereferencing pointer to incomplete type
make[4]: *** [gtkprintbackendcups.lo] Ошибка 1
make[4]: Выход из каталога `/tmp/yaourt-tmp-den/aur-gtk3-git/src/gtk+-build/modules/printbackends/cups'
make[3]: *** [all-recursive] Ошибка 1
make[3]: Выход из каталога `/tmp/yaourt-tmp-den/aur-gtk3-git/src/gtk+-build/modules/printbackends'
make[2]: *** [all-recursive] Ошибка 1
make[2]: Выход из каталога `/tmp/yaourt-tmp-den/aur-gtk3-git/src/gtk+-build/modules'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/tmp/yaourt-tmp-den/aur-gtk3-git/src/gtk+-build'
make: *** [all] Ошибка 2

Anonymous comment on 2012-05-04 17:18

@akulikov It seems that pango-unstable is a lower version than gtk3 needs, the regular pango (in the extra repo I think) is actually a higher version (1.30.1 I think).

And I had the same problems as EvilSakray

Anonymous comment on 2012-04-04 21:27

configure: error: Package requirements (glib-2.0 >= 2.32.0 atk >= 2.2.0 pango >= 1.30.0 cairo >= 1.10.0 cairo-gobject >= 1.10.0 gdk-pixbuf-2.0 >= 2.26.0) were not met:

Requested 'pango >= 1.30.0' but version of Pango is 1.29.3
Requested 'gdk-pixbuf-2.0 >= 2.26.0' but version of GdkPixbuf is 2.24.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ОШИБКА: Произошел сбой в build().
Преждевременный выход...
==> ERROR: Makepkg was unable to build .

Anonymous comment on 2012-03-31 16:02

After some search, this come from the configuration generated. (the flag --enable-wayland-backend) seems to be responsible for the error encountered when attempting to make.

Anonymous comment on 2012-03-30 23:27

Isn't building for me:
../../gdk/gdkconfig.h:13:18: fatal error: glib.h: No such file or directory.

glib2-git is installed ofc.

Anonymous comment on 2012-03-19 12:49

As alorewotik said, the latest build requires gdk-pixbuf 2.25