Package Details: gtk4-git 3.94.0.r400.g0edec9bcae-1

Git Clone URL: https://aur.archlinux.org/gtk4-git.git (read-only)
Package Base: gtk4-git
Description: GObject-based multi-platform GUI toolkit (GIT Version)
Upstream URL: https://www.gtk.org/
Licenses: LGPL
Submitter: andrewSC
Maintainer: andrewSC
Last Packager: andrewSC
Votes: 15
Popularity: 0.000258
First Submitted: 2016-11-18 20:17
Last Updated: 2018-09-10 16:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

ivdok commented on 2013-10-31 02:57

Bumped Git to 2.39 manually, via editing PKGBUILD. Compiles steadily.

ivdok commented on 2013-10-31 02:23

...
checking for wayland-scanner... /usr/bin/wayland-scanner
checking whether build environment is sane... yes
checking for BASE_DEPENDENCIES... no
configure: error: Package requirements (glib-2.0 >= 2.39.0 atk >= 2.7.5 pango >= 1.32.4 cairo >= 1.12.0 cairo-gobject >= 1.12.0 gdk-pixbuf-2.0 >= 2.27.1) were not met:

Requested 'glib-2.0 >= 2.39.0' but version of GLib is 2.37.8

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build gtk3-git.


Did not yet tried glib2-git, but version number is surely ~2.37.

andrewSC commented on 2013-08-21 12:40

@lubosz: Updated the PKGBUILD to include $pkgver
@garyvdm: I've updated the deps list but I had to use libx11-git and xproto-git to get around some undefined refs during compilation.

NOTE: If any of you have the same ref failures I got (or any ref failures at all) just ping me here and I'll take a look into it. Also, thanks for the patience--still not entirely settled in yet but this needed to get done.

andrewSC commented on 2013-08-08 14:20

Sorry guys, been a bit backed up--I'll try to wrap up your requests over the weekend

lubosz commented on 2013-08-03 13:55

could you please do
provides=('gtk3='$pkgver)

since it exposes a more accurate version

lubosz commented on 2013-08-03 13:55

could you please do
provides=('gtk3='$pkgver)

since it exposes a more accurate version

haawda commented on 2013-07-31 18:37

better use provides=("gtk3=$pkgver"), its easier to maintain.

garyvdm commented on 2013-07-10 10:19

When building 3.9.8.3.g5ae57fc:
glib2-git is required. A number of other -git packages are not required. I built and ran with:

depends=('atk' 'cairo' 'gtk-update-icon-cache' 'libcups' 'libxcursor' \
'libxinerama' 'libxrandr' 'libxi' 'libxcomposite' 'libxdamage' 'pango' \
'shared-mime-info' 'colord' 'at-spi2-atk' 'wayland-git' 'libxkbcommon' \
'glib2-git')

andrewSC commented on 2013-06-12 22:52

@lubosz updated

lubosz commented on 2013-06-12 13:41

please build the package before making "makepkg --source", so the version is not like pkgver=20130429 but pkgver=3.9.2.35.g5cb26cb